当前位置:网站首页>二叉搜索树解决落叶问题
二叉搜索树解决落叶问题
2022-08-03 22:41:00 【chengqiuming】
一 原问题链接
Falling Leaves - POJ 1577 - Virtual Judgehttps://vjudge.net/problem/POJ-1577
二 输入和输出
1 输入
输入包含多个测试用例。每个测试用例都是一行或多行大写字母序列,每行都给出按上述步骤从二叉搜索树中删除的叶子,每行给出的字母都按字母升序排列。在测试用例之间以一行分隔,该行仅包含一个星号,在最后一个测试用例后给出一行,该行仅给出一个美元符号。在输入中没有空格或空行。
2 输出
对于每个测试用例,都有唯一的二叉搜索树,单行输出该树的先序遍历。
三 输入和输出样例
1 输入样例
BDHPY
CM
GQ
K
*
AC
B
$
2 输出样例
KGCBDHQMPY
BAC
四 算法设计
最后一个字母一定为树根,先输入的字母在树的深层,可以逆序建树。读入字母序列后用字符串存储,然后逆序创建二叉搜索树,将小的字母插入左子树,将大的字母插入右子树。输出该树的先序遍历:根,左子树,右子树。
五 代码
package poj1577;
import java.util.Scanner;
public class Poj1577 {
static int cnt = 1;
static data tree[] = new data[110];
static void insert(int t, char ch) {
if (tree[t].c == 0) {
tree[t].c = ch;
return;
}
if (ch < tree[t].c) {
if (tree[t].l == 0) {
tree[++cnt].c = ch;
tree[t].l = cnt;
} else
insert(tree[t].l, ch);
}
if (ch > tree[t].c) {
if (tree[t].r == 0) {
tree[++cnt].c = ch;
tree[t].r = cnt;
} else
insert(tree[t].r, ch);
}
}
static void preorder(int t) {
if (tree[t].c == 0)
return;
System.out.print(tree[t].c);
preorder(tree[t].l);
preorder(tree[t].r);
}
public static void main(String[] args) {
String s1, s;
while (true) {
s = "";
for (int i = 0; i < tree.length; i++) {
tree[i] = new data();
}
Scanner scanner = new Scanner(System.in);
while (true) {
s1 = scanner.next();
if (s1.charAt(0) != '*' && s1.charAt(0) != '$') {
s += s1;
} else {
break;
}
}
for (int i = s.length() - 1; i >= 0; i--)
insert(1, s.charAt(i));
preorder(1);
System.out.println();
if (s1.charAt(0) == '$')
break;
}
}
}
class data {
int l;
int r;
char c;
}
六 测试
绿色为输入,白色为输出。
边栏推荐
猜你喜欢
Fluorescein-PEG-CLS,胆固醇-聚乙二醇-荧光素科研试剂
藏宝计划TreasureProject(TPC)系统模式开发技术原理
noip初赛
PowerMockup 4.3.4::::Crack
直播预告 | 构建业务智联,快速拥抱财务数字化转型
Bytebase database schema change management tool
node连接mysql数据库报错:Client does not support authentication protocol requested by server
[MySQL Advanced] Creation and Management of Databases and Tables
Cisco ike2 IPSec配置
navicat 连接 mongodb 报错[13][Unauthorized] command listDatabases requires authentication
随机推荐
【云原生实用技巧】使用 skopeo 批量同步 helm chart 依赖镜像
488. Zuma Game
RPA power business automation super order!
L2-029 特立独行的幸福
override learning (parent and child)
老板:公司系统太多,能不能实现账号互通?
云计算国内外发展现状
重发布实验报告
Basic Concepts of Graphs
【bug】汇总Elipse项目中代码中文乱码解决方法!
目标检测的国内外研究现状
UVa 10003 - Cutting Sticks (White Book, Interval DP)
Nine ways to teach you to read the file path in the resources directory
九种方式,教你读取 resources 目录下的文件路径
Codeup刷题笔记-简单模拟
pikachu Over permission 越权
The development status of cloud computing at home and abroad
480. Sliding Window Median
Why do we need callbacks
Embedded Systems: Clocks