当前位置:网站首页>Zzuli:1047 logarithmic table
Zzuli:1047 logarithmic table
2022-07-03 14:34:00 【Snake_____】
Title Description
Enter two positive integers m and n, Output m To n The natural logarithm of each integer between .
Input
The input includes two integers m and n(m<=n), Separated by a space .
Output
Each line outputs an integer and its logarithm , The whole number takes up 4 Column , Logarithmic proportion 8 Column , Right alignment , Logarithmic reservation 4 Decimal place .
The sample input Copy
2 4
Sample output Copy
2 0.6931 3 1.0986 4 1.3863
#include <stdio.h>
#include <math.h>
int main()
{
int n,m,i;
scanf("%d%d",&m,&n);
for(i=m;i<=n;i++)
{
printf("%4d%8.4f\n",i,log(i));
}
return 0;
}
边栏推荐
- ConstraintLayout 的使用
- How Facebook moves instagram from AWS to its own server
- 常见问题之PHP——ldap_add(): Add: Undefined attribute type in
- Tailing rushes to the scientific and Technological Innovation Board: it plans to raise 1.3 billion, and Xiaomi Changjiang is the shareholder
- 中国锂电池电解液行业市场专项调研报告(2022版)
- Analysis of gene family characteristics - chromosome location analysis
- 7-15 calculation of PI
- Thinking about the arrangement problem in the backtracking problem (leetcode questions 46 and 47)
- Bibit pharmaceutical rushed to the scientific innovation board: annual revenue of 970000, loss of 137million, proposed to raise 2billion
- 编程语言:类型系统的本质
猜你喜欢
剑指 Offer 28. 对称的二叉树
天谋科技 Timecho 完成近亿元人民币天使轮融资,打造工业物联网原生时序数据库
Bibit pharmaceutical rushed to the scientific innovation board: annual revenue of 970000, loss of 137million, proposed to raise 2billion
Leetcode (4) - - trouver la médiane de deux tableaux ordonnés positifs
Polestar美股上市:5.5万台交付如何支持得起超200亿美元估值
洛谷P4047 [JSOI2010]部落划分 题解
分布式事务(Seata) 四大模式详解
puzzle(016.4)多米诺效应
Happy capital new dual currency fund nearly 4billion yuan completed its first account closing
X86 assembly language - Notes from real mode to protected mode
随机推荐
Protobuf and grpc
Preliminary summary of structure
556. 下一个更大元素 III
LNMP环境mail函数不能发送邮件解决
String reverse order
Find specified characters
Comprehensive evaluation of good-looking, easy-to-use and powerful handwriting note taking software: notability, goodnotes, marginnote, handwriting, notes writers, collanote, collanote, prodrafts, not
Analysis of gene family characteristics - chromosome location analysis
Stop asking yourself if you are suitable for software testing
Statistical capital consonants
Plane vector addition
超简单手机地图开发
Table of mathematical constants by q779
Accelerating strategy learning using parallel differentiable simulation
7-28 monkeys choose King (Joseph problem)
Timecho of Tianmou technology completed an angel round financing of nearly 100 million yuan to create a native timing database of the industrial Internet of things
Ultra simple mobile map development
洛谷P4047 [JSOI2010]部落划分 题解
Tonybot Humanoïde Robot Infrared Remote play 0630
Zhejiang University Edition "C language programming (4th Edition)" topic set reference ideas set