当前位置:网站首页>矩阵翻转(数组模拟)
矩阵翻转(数组模拟)
2022-07-04 17:59:00 【相思明月楼】
问题
晓萌最近在做一个翻转图片的应用,你可能也知道,图片其实是由一个个的点组成的。于是,晓萌想先做一个可以翻转矩阵的程序,来解决他问题的核心部分。
输入格式
输入第一行包括由空格分开的整数 M,N,T(0 < N,M < 200)M,N,T(0<N,M<200),TT 的值为 00 或 11。其中 MM 和 NN 分别表示待处理矩阵的行数与列数,TT 为 00 时表示左右翻转,为 11 时表示上下翻转。
之后的 MM 行,每行包括由空格分隔的 NN 个整数,依次为输入矩阵的每一行的数据。
输出格式
输出包括 MM 行 NN 列,每个数字之间用一个空格分隔,每一行行末均有一个空格,表示的是按照要求翻转后的矩阵。
样例输入
4 4 1 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
样例输出
3 4 5 6 9 0 1 2 5 6 7 8 1 2 3 4
直接用数组模拟。
#include <iostream>
#include <cstdio>
using namespace std;
const int MAXN = 210;
int mp[MAXN][MAXN];
int main() {
int m, n, t;
scanf("%d %d %d", &m, &n, &t);
for(int i = 0; i < m; i++) {
for(int j = 0; j < n; j++) {
scanf("%d", &mp[i][j]);
}
}
if(t == 1) {
for(int i = m - 1; i >= 0; i--) {
for(int j = 0; j < n; j++) {
printf("%d ", mp[i][j]);
}
printf("\n");
}
} else {
for(int i = 0; i < m; i++) {
for(int j = n - 1; j >= 0; j--) {
printf("%d ", mp[i][j]);
}
printf("\n");
}
}
return 0;
}
边栏推荐
- 26. Delete the duplicate item C solution in the ordered array
- 在线SQL转Excel(xls/xlsx)工具
- How test engineers "attack the city" (Part I)
- . Net ORM framework hisql practice - Chapter 2 - using hisql to realize menu management (add, delete, modify and check)
- Shell 編程核心技術《四》
- 反射(一)
- Bi skills - permission axis
- Have you guys ever used CDC direct Mysql to Clickhouse
- 读写关闭的channel是啥后果?
- Shell 编程核心技术《四》
猜你喜欢
使用canal配合rocketmq监听mysql的binlog日志
千万不要只学 Oracle、MySQL!
更安全、更智能、更精致,长安Lumin完虐宏光MINI EV?
Use canal and rocketmq to listen to MySQL binlog logs
PolyFit软件介绍
2022CoCa: Contrastive Captioners are Image-Text Fountion Models
【问题】druid报异常sql injection violation, part alway true condition not allow 解决方案
在线文本行固定长度填充工具
[release] a tool for testing WebService and database connection - dbtest v1.0
自由小兵儿
随机推荐
爬虫(6) - 网页数据解析(2) | BeautifulSoup4在爬虫中的使用
The 15th youth informatics competition in Shushan District in 2019
How test engineers "attack the city" (Part I)
反射(一)
神经网络物联网应用技术就业前景【欢迎补充】
Other InterSystems%net tools
数组中的第K个最大元素
Unity编辑器扩展C#遍历文件夹以及子目录下的所有图片
26. Delete the duplicate item C solution in the ordered array
[uniapp] uniapp development app online Preview PDF file
DeFi生态NFT流动性挖矿系统开发搭建
Caché WebSocket
Hough Transform 霍夫变换原理
英特尔集成光电研究最新进展推动共封装光学和光互连技术进步
2022养生展,健康展,北京大健康展,健康产业展11月举办
PolyFit软件介绍
The 300th weekly match of leetcode (20220703)
问下各位大佬有用过cdc直接mysql to clickhouse的么
26. 删除有序数组中的重复项 C#解答
Cache é JSON uses JSON adapters