当前位置:网站首页>-查找数-
-查找数-
2022-08-03 05:10:00 【-JMY-】
题目描述
已知一个长度为10且已经按照从小到大排序的整形数组,要求对于输入的每一个整数,判断该数在数组中的位置并且输出。如果数组中不存在这个数,输出error.
输入
输入10个数,顺序从小到大,输入一个n ,n代表随后要查找n次,随后输入n个要查找的数。
输出
输出查找的结果。
样例输入
1 2 3 4 5 6 7 8 9 10 5 1 4 7 8 11
样例输出
1 4 7 8 error
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
bool flag;
int a[11],b[10005],n;
for(int i=1;i<=10;i++)
scanf("%d",a+i);
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",b+i);
for(int i=1;i<=n;i++){
flag=true;
for(int j=1;j<=10;j++){
if(b[i]==a[j]){
flag=false;
printf("%d\n",j);
break;
}
}
if(flag)
printf("error\n");
}
}
边栏推荐
猜你喜欢
随机推荐
web安全-命令执行漏洞
minio下载文件乱码或者是一条横线
HarmonyOS应用开发培训第二次作业
接口和抽象
【 Harmony OS 】 【 ano UI 】 lightweight data storage
typescript49-交叉类型
Shell conditional statement judgment
Redis常用命令
Harmony OS ets ArkUI 】 【 】 the development basic page layout and data connection
Super handy drawing tool is recommended
typescript44-对象之间的类兼容器
shell脚本循环语句
1058 选择题 (20 分)(C语言)
Harmony OS Date ano UI 】 【 】 the basic operation
typescript39-class类的可见修饰符
用scikit-learn学习谱聚类
Talking about GIS Data (5) - Geographic Coordinate System
【Harmony OS】【ARK UI】ets use startAbility or startAbilityForResult to invoke Ability
2. 两数相加
vim命令