当前位置:网站首页>1064 Complete Binary Search Tree
1064 Complete Binary Search Tree
2022-07-30 21:33:00 【Brosto_Cloud】
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
对于BST,其中序遍历是非递减数列,所以先从小到大排序,按照中序遍历来建树,然后按序号输出(即层序遍历)即可:
#include <iostream>
#include <algorithm>
using namespace std;
int a[1010], n, ans[1010], cnt;
void dfs(int x) {
if (x <= n) {
dfs(x * 2);
ans[x] = a[cnt++];
dfs(x * 2 + 1);
}
}
int main() {
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a[i];
}
sort(a, a + n);
dfs(1);
for (int i = 1; i <= n; i++) {
cout << ans[i];
if (i != n) {
cout << ' ';
}
}
return 0;
}
边栏推荐
猜你喜欢
【零代码工具】15 款企业级零代码开发平台推荐,总有一款是你心仪的
系统结构考点之并行主存
MySql创建数据表
一个网络两种用途!南开&哈工程提出TINet,通过细化纹理和边缘,在显著性目标检测和伪装目标检测上实现双SOTA!...
活动推荐 | 2022年深圳最值得参加的边缘计算活动
Typescript 严格模式有多严格?
MySQL60题作业
解决npm warn config global `--global`, `--local` are deprecated. use `--location=global` instead
How strict Typescript strict mode?
系统结构考点之CRAY-1向量处理机
随机推荐
About the data synchronization delay of MySQL master-slave replication
Simple configuration of three-tier architecture
ClickHouse 数据插入、更新与删除操作 SQL
小心你的字典和样板代码
Navigation Bar----Personal Center Dropdown
mysql deadlock
go语言慢速入门——流程控制语句
系统结构考点之并行计算霍纳法则
牛客小白月赛53 A-E
基于ABP实现DDD--领域服务、应用服务和DTO实践
mysql 时间字段默认设置为当前时间
【深度学习】目标检测|SSD原理与实现
登堂入室之soc开发makefile
GPGGA NTRIP RTCM 笔记
GPGGA NTRIP RTCM Notes
导航栏----个人中心 Dropdown
go慢速入门——函数
MySQL user authorization
Union, the difference between union and structure, the knowledge of enumeration of C language corners
Google Earth Engine ——