当前位置:网站首页>求因子数量
求因子数量
2022-08-03 05:10:00 【-JMY-】
题目描述
从键盘读入一个整数n(n<=100),请求出1~n的每个数的因子个数(求因子个数时,不含1和自己,比如10只有2个因子),每行一个打印出来。
输入
一个整数n
输出
n行,每行一个整数,代表了每个整数的因子个数
样例输入
10
样例输出
0 0 0 1 0 2 0 2 1 2
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
int n,s;
scanf("%d",&n);
for(int i=1;i<=n;i++){
s=0;
for(int j=2;j<=sqrt(i);j++)
if(i%j==0)
s+=2;
if(float(sqrt(i))==int(sqrt(i))&&i!=1)
s--;
printf("%d\n",s);
}
}
边栏推荐
猜你喜欢
IO process thread -> thread -> day5
13.
lt.647. Palindromic substring + lt.516. Longest palindrome subsequence Detailed explanation of MOSN reverse channel
Common lipophilic cell membrane dyes DiO, Dil, DiR, Did spectrograms and experimental procedures
CAD有生僻字如何打出来、如何提交软件相关问题或建议?
UV decomposition of biotin - PEG2 - azide | CAS: 1192802-98-4 biotin connectors
【转】最小描述长度准则MDL(Minimun Description Length)
tag单调栈-单调栈预备知识-lt.739. 每日温度
flask 面试题 问题
Kaggle 入门(Kaggle网站使用及项目复现)
随机推荐
生活原则。
typescript46-函数之间的类型兼容性
阿凡提的难题
User password verification
1058 选择题 (20 分)(C语言)
odps的临时查询能在写sql的时候就给结果一个命名不?
阿里云对象存储oss私有桶生成链接
JDBC与连接池
MCM box model modeling method and source analysis of atmospheric O3
初步认识ZK
[Fine talk] Using native js to implement todolist
曲线特征----曲线弯曲程度的探究
Get the Ip tool class
1079 延迟的回文数 (20 分)
User password encryption tool
在树莓派上搭建属于自己的网页(1)
用scikit-learn学习谱聚类
Build your own web page on raspberry pie (1)
Harmony OS Date ano UI 】 【 】 the basic operation
HarmonyOS应用开发第一次培训