当前位置:网站首页>-寻找鞍点-
-寻找鞍点-
2022-08-03 05:10:00 【-JMY-】
题目描述
给定一个5*5的矩阵,每行只有一个最大值,每列只有一个最小值,寻找这个矩阵的鞍点。鞍点指的是矩阵中的一个元素,它是所在行的最大值,并且是所在列的最小值。
例如:在下面的例子中(第4行第1列的元素就是鞍点,值为8 )。
11 3 5 6 9
12 4 7 8 10
10 5 6 9 11
8 6 4 7 2
15 10 11 20 25
输入
输入包含一个5行5列的矩阵
输出
如果存在鞍点,输出鞍点所在的行、列及其值,如果不存在,输出"not found"
样例输入
11 3 5 6 9 12 4 7 8 10 10 5 6 9 11 8 6 4 7 2 15 10 11 20 25
样例输出
4 1 8
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
int a[10][10],b=-1,c=1000,x=0,y=0;
for(int i=1;i<=5;i++)
{
for(int j=1;j<=5;j++)
{
cin>>a[i][j];
}
}
for(int j=1;j<=5;j++)
{
for(int i=1;i<=5;i++)
{
if(a[j][i]>b){b=a[j][i];x=i;}
}
for(int i=1;i<=5;i++)
{
if(a[i][x]<c){c=a[i][x];y=i;}
}
if(c==b){cout<<y<<" "<<x<<" "<<c;return 0;}
b=-1;c=1000;x=0;y=0;
}
cout<<"not found";
}
边栏推荐
猜你喜欢
随机推荐
【HMS core】【Ads Kit】Huawei Advertising——Overseas applications are tested in China. Official advertisements cannot be displayed
breed Web刷机升级详细教材修正编译器固件说明_itkeji.top
Peptides mediated PEG DSPE of phospholipids, targeted functional materials - PEG - RGD/TAT/NGR/APRPG
【Harmony OS】【ARK UI】ets use startAbility or startAbilityForResult to invoke Ability
Gradle的安装配置
1089 狼人杀-简单版 (20 分)
Js学习笔记(四)
User password verification
Interface test Mock combat (2) | Combined with jq to complete batch manual Mock
深度学习入门之GRU
Common fluorescent dyes to modify a variety of groups and its excitation and emission wavelength data in the data
2022暑假牛客多校联赛第一场
PotPlayer实现上班摸鱼电视自由
Common lipophilic cell membrane dyes DiO, Dil, DiR, Did spectrograms and experimental procedures
idea使用@Autowired注解爆红原因及解决方法
数字孪生园区场景中的坐标知识
轨迹(形状)相似性判断与度量方法
shell脚本循环语句
1058 选择题 (20 分)(C语言)
2017-06-11 Padavan 完美适配newifi mini【adbyby+SS+KP ...】youku L1 /小米mini