当前位置:网站首页>外卖店优先级
外卖店优先级
2022-08-04 03:08:00 【Ding Jiaxiong】
题目
“饱了么”外卖系统中维护着 N 家外卖店,编号 1∼N。
每家外卖店都有一个优先级,初始时 (0 时刻) 优先级都为 0。
每经过 1 个时间单位,如果外卖店没有订单,则优先级会减少 1,最低减到 0;而如果外卖店有订单,则优先级不减反加,每有一单优先级加 2。
如果某家外卖店某时刻优先级大于 5,则会被系统加入优先缓存中;如果优先级小于等于 3,则会被清除出优先缓存。
给定 T 时刻以内的 M 条订单信息,请你计算 T 时刻时有多少外卖店在优先缓存中。
输入格式
第一行包含 3 个整数 N,M,T。
以下 M 行每行包含两个整数 ts 和 id,表示 ts 时刻编号 id 的外卖店收到一个订单。
输出格式
输出一个整数代表答案。
数据范围
1≤N,M,T≤105,
1≤ts≤T,
1≤id≤N
输入样例:
2 6 6
1 1
5 2
3 1
6 2
2 1
6 2
输出样例:
1
样例解释
6 时刻时,1 号店优先级降到 3,被移除出优先缓存;2 号店优先级升到 6,加入优先缓存。
所以是有 1 家店 (2 号) 在优先缓存中。
思路分析
题解
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define x first
#define y second
using namespace std;
typedef pair<int , int > PII;
const int N = 100010;
int n , m , T;
int last[N],score[N];
bool st[N];
PII order[N]; //所有订单
int main(){
scanf("%d%d%d",&n , &m , &T);
for(int i = 0 ; i < m; i++){
scanf("%d%d",&order[i].x , &order[i].y);
}
sort(order , order + m);
//枚举每个订单
for(int i = 0; i < m ;){
int j = i;
while(j < m && order[j] == order[i]){
j ++;
}
int t = order[i].x , id = order[i].y , cnt = j - i;
i = j;
score[id] -= t - last[id] - 1;
if(score[id] < 0){
score[id] = 0;
}
if(score[id] <= 3){
st[id] = false;
}
// 以上T时刻之前
score[id] += cnt * 2;
if(score[id] > 5){
st[id] = true;
}
last[id] = t;
}
for(int i = 1;i <= n; i++){
if(last[i] < T){
score[i] -= T - last[i];
if(score[i] <= 3){
st[i] = false;
}
}
}
// 统计
int res = 0;
for(int i = 1; i <= n; i++){
res += st[i];
}
printf("%d\n",res);
return 0;
}
边栏推荐
- 如何在MySQL中的数据库下删除所有的表
- docker+网桥+redis主从+哨兵模式
- Deep Learning (3) Classification Theory Part
- unsafe.Pointer, pointer, reference in golang
- Big guys, it takes a long time to read mysql3 million single tables, what parameters can be discounted, or is there any way to hurry up
- 案例 | 重庆银行流动数据安全挑战及应对实践
- new Date将字符串转化成日期格式 兼容IE,ie8如何通过new Date将字符串转化成日期格式,js中如何进行字符串替换, replace() 方法详解
- View mysql deadlock syntax
- 创新互融|华秋赋能助力OpenHarmony生态硬件开发落地
- 小程序+新零售,玩转行业新玩法!
猜你喜欢
全网没有之一的JMeter 接口测试流程详解
There are too many systems, how to realize multi-account interworking?
SQL注入中 #、 --+、 --%20、 %23是什么意思?
STM8S105K4T6------Serial port sending and receiving
十一种概率分布
跨境电商看不到另一面:商家刷单、平台封号、黑灰产牟利
深度学习(三)分类 理论部分
pytorch应用于MNIST手写字体识别
一文看懂推荐系统:召回04:离散特征处理,one-hot编码和embedding特征嵌入
系统太多,多账号互通如何实现?
随机推荐
Polygon zkEVM network node
数据安全峰会2022 | 美创DSM获颁“数据安全产品能力验证计划”评测证书
golang中的unsafe.Pointer,指针,引用
SQL注入中 #、 --+、 --%20、 %23是什么意思?
Homemade bluetooth mobile app to control stm8/stm32/C51 onboard LED
用户与用户互发红包/支付宝C2C/B2C现金红包php源码示例/H5方式/兼容苹果/安卓
自制蓝牙手机app控制stm8/stm32/C51板载LED
自定义通用分页标签02
在更一般意义上验算移位距离和假设
Power button (LeetCode) 215. The first K largest elements in the array (2022.08.03)
sql注入一般流程(附例题)
Mockito单元测试
Polygon zkEVM网络节点
网络工程师入门必懂华为认证体系,附系统学习路线分享
6口全千兆二层网管型工业以太网交换机千兆2光4电光纤自愈ERPS环网交换机
Rongyun "Audio and Video Architecture Practice" technical session [complete PPT included]
ingress 待完善
STM8S project creation (STVD creation) --- use COSMIC to create a C language project
pnpm 是凭什么对 npm 和 yarn 降维打击的
SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropri