当前位置:网站首页>POJ1287联网题解
POJ1287联网题解
2022-08-01 07:05:00 【bj_hacker】
题目
链接
http://poj.org/problem?id=1287
字面描述
Networking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30043 Accepted: 15117
Description
You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0
2 3
1 2 37
2 1 17
1 2 68
3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32
5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12
0
Sample Output
0
17
16
26
Source
Southeastern Europe 2002
代码实现
模板题,思路不展示
#include<cstdio>
#include<string.h>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=100+10;
const int inf=2e9;
int n,ans,m;
int lowcost[maxn];
int c[maxn][maxn];
bool vis[maxn];
inline void Prim(){
//初始化
memset(vis,false,sizeof(vis));
ans=0;
vis[1]=true;
for(int i=1;i<=n;i++)lowcost[i]=c[1][i];
//n-1条边的添加
for(int i=1;i<n;i++){
int temp=inf;
int t=1;
//寻找离已添加最近的节点t
for(int j=1;j<=n;j++){
if(!vis[j]&&lowcost[j]<temp){
temp=lowcost[j];
t=j;
}
}
ans+=temp;
if(t==1)break;
vis[t]=true;
//更新未添加节点
for(int j=1;j<=n;j++){
if(!vis[j]&&c[t][j]<lowcost[j])lowcost[j]=c[t][j];
}
}
}
int main(){
while(1){
scanf("%d",&n);
if(!n)break;
scanf("%d",&m);
memset(c,0x3f,sizeof(c));
for(int i=1;i<=m;i++){
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
c[u][v]=min(c[u][v],w);
c[v][u]=min(c[v][u],w);
}
Prim();
printf("%d\n",ans);
}
return 0;
}
边栏推荐
- 特别数的和
- Upgrade to heavyweight lock, lock reentrancy will lead to lock release?
- Detailed explanation of the crawler framework Scrapy
- 基于MATLAB的BP神经网络进行语音特征信号分类
- curl (7) Failed connect to localhost8080; Connection refused
- 响应式织梦模板园林景观类网站
- 小白的0基础教程SQL: 安装MYSQL 03
- 2022.7.27 Selected lectures on good topics
- 2022杭电多校第二场1011 DOS Card(线段树)
- Golang:go连接和使用mysql
猜你喜欢
响应式织梦模板园林花卉类网站
自制一款远程控制软件——VeryControl
Vim简介
Dell PowerEdge Server R450 RAID Configuration Steps
戴尔PowerEdge服务器R450 RAID配置步骤
How to use Photoshop to composite star trail photos, post-processing method of night sky star trail photos
NIO programming
Detailed explanation of the crawler framework Scrapy
MVVM项目开发(商品管理系统一)
旋度(7)连接失败localhost8080;连接拒绝了
随机推荐
从底层结构开始学习FPGA(6)----分布式RAM(DRAM,Distributed RAM)
Why is the lightweight VsCode used more and more?Why eat my C drive 10G?How to Painlessly Clean VsCode Cache?Teach you how to lose weight for C drive
配置我的kitty
mysql的行锁和间隙锁
Offer brush questions - 1
拳头游戏免版权音乐下载,英雄联盟无版权音乐,可用于视频创作、直播
Explosive 30,000 words, the hardest core丨Mysql knowledge system, complete collection of commands [recommended collection]
声音信号处理基频检测和时频分析
自制一款远程控制软件——VeryControl
第02章 MySQL的数据目录【1.MySQL架构篇】【MySQL高级】
电磁兼容简明教程(6)测试项目
零代码网站开发利器:WordPress
目标检测概述-上篇
Does flinkcdc have any solution for mysql's date field type conversion?
Offer刷题——1
Electromagnetic compatibility introductory tutorial (6) test project
图片无损压缩软件哪个好用:试试完全免费的JPG-C 图片批量修整压缩减肥工具吧 | 最新jpg批量修整工具下载
2022.7.27 Selected lectures on good topics
How to use Photoshop to composite star trail photos, post-processing method of night sky star trail photos
升级为重量级锁,锁重入会导致锁释放?