当前位置:网站首页>1009 product of polynomials (25 points) (PAT class a)
1009 product of polynomials (25 points) (PAT class a)
2022-07-04 19:37:00 【Acacia moon tower】
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
Multiplication of polynomials .
#include <iostream>
using namespace std;
int main() {
int n1, n2, a, cnt = 0;
scanf("%d", &n1);
double b, arr[1001] = {0.0}, ans[2001] = {0.0};
for(int i = 0; i < n1; i++) {
scanf("%d %lf", &a, &b);
arr[a] = b;
}
scanf("%d", &n2);
for(int i = 0; i < n2; i++) {
scanf("%d %lf", &a, &b);
for(int j = 0; j < 1001; j++)
ans[j + a] += arr[j] * b;
}
for(int i = 2000; i >= 0; i--) {
if(ans[i] != 0.0) {
cnt++;
}
}
printf("%d", cnt);
for(int i = 2000; i >= 0; i--) {
if(ans[i] != 0.0) {
printf(" %d %.1f", i, ans[i]);
}
}
return 0;
}
边栏推荐
- BCG 使用之新建向导效果
- 关于判断点是否位于轮廓内的一点思考
- 1002. A+b for Polynomials (25) (PAT class a)
- Qt实现界面滑动切换效果
- Pointnet/Pointnet++点云数据集处理并训练
- 1006 sign in and sign out (25 points) (PAT class a)
- Online text line fixed length fill tool
- 1007 maximum subsequence sum (25 points) (PAT class a)
- QT realizes interface sliding switching effect
- Jetpack Compose 教程
猜你喜欢
FPGA时序约束分享01_四大步骤简述
92. (cesium chapter) cesium building layering
Online sql to excel (xls/xlsx) tool
如何使用Async-Awati异步任务处理代替BackgroundWorker?
Online text line fixed length fill tool
abc229 总结(区间最长连续字符 图的联通分量计数)
Pointnet/Pointnet++点云数据集处理并训练
OpenCV的二值化处理函数threshold()详解
Explore the contour drawing function drawcontours() of OpenCV in detail with practical examples
C# 使用StopWatch测量程序运行时间
随机推荐
How to use async Awati asynchronous task processing instead of backgroundworker?
kotlin 基本使用
ftp、sftp文件传输
Functional interface
English语法_名词 - 使用
Pythagorean number law (any three numbers can meet the conditions of Pythagorean theorem)
Hough transform Hough transform principle
"Only one trip", active recommendation and exploration of community installation and maintenance tasks
Comment utiliser async awati asynchrone Task Handling au lieu de backgroundworker?
Shell 编程核心技术《二》
安徽 中安在线文旅频道推出“跟着小编游安徽”系列融媒体产品
Shell 编程核心技术《一》
Online sql to excel (xls/xlsx) tool
BCG 使用之新建向导效果
TCP两次挥手,你见过吗?那四次握手呢?
The kth largest element in the array
如何使用Async-Awati异步任務處理代替BackgroundWorker?
如何使用Async-Awati异步任务处理代替BackgroundWorker?
1007 Maximum Subsequence Sum(25 分)(PAT甲级)
Jetpack compose tutorial