当前位置:网站首页>HDU 6440 2018 Chinese college student program design network competition
HDU 6440 2018 Chinese college student program design network competition
2022-07-04 19:36:00 【Acacia moon tower】
Problem Description
Freshmen frequently make an error in computing the power of a sum of real numbers, which usually origins from an incorrect equation (m+n)p=mp+np, where m,n,p are real numbers. Let's call it ``Beginner's Dream''.
For instance, (1+4)2=52=25, but 12+42=17≠25. Moreover, 9+16−−−−−√=25−−√=5, which does not equal 3+4=7.
Fortunately, in some cases when p is a prime, the identity
(m+n)p=mp+np
holds true for every pair of non-negative integers m,n which are less than p, with appropriate definitions of addition and multiplication.
You are required to redefine the rules of addition and multiplication so as to make the beginner's dream realized.
Specifically, you need to create your custom addition and multiplication, so that when making calculation with your rules the equation (m+n)p=mp+np is a valid identity for all non-negative integers m,n less than p. Power is defined as
ap={1,ap−1⋅a,p=0p>0
Obviously there exists an extremely simple solution that makes all operation just produce zero. So an extra constraint should be satisfied that there exists an integer q(0<q<p) to make the set {qk|0<k<p,k∈Z} equal to {k|0<k<p,k∈Z}. What's more, the set of non-negative integers less than p ought to be closed under the operation of your definitions.
Hint
Hint for sample input and output:
From the table we get 0+1=1, and thus (0+1)2=12=1⋅1=1. On the other hand, 02=0⋅0=0, 12=1⋅1=1, 02+12=0+1=1.
They are the same.
Input
The first line of the input contains an positive integer T(T≤30) indicating the number of test cases.
For every case, there is only one line contains an integer p(p<210), described in the problem description above. p is guranteed to be a prime.
Output
For each test case, you should print 2p lines of p integers.
The j-th(1≤j≤p) integer of i-th(1≤i≤p) line denotes the value of (i−1)+(j−1). The j-th(1≤j≤p) integer of (p+i)-th(1≤i≤p) line denotes the value of (i−1)⋅(j−1).
Sample Input
1
2
Sample Output
0 1
1 0
0 0
0 1
#include <iostream>
#include <stdio.h>
using namespace std;
int main() {
int t, p;
scanf("%d", &t);
while(t--) {
scanf("%d", &p);
for(int i = 1; i <= p; i++) {
for(int j = 1; j <= p; j++) {
j==p?printf("%d\n", ((i-1)+(j-1))%p):printf("%d ", ((i-1)+(j-1))%p);
}
}
for(int i = 1; i <= p; i++) {
for(int j = 1; j <= p; j++) {
j==p?printf("%d\n", ((i-1)*(j-1))%p):printf("%d ", ((i-1)*(j-1))%p);
}
}
}
return 0;
}
边栏推荐
- Leetcode fizzbuzz C # answer
- The kth largest element in the array
- 如何使用Async-Awati异步任务处理代替BackgroundWorker?
- 876. Intermediate node of linked list
- Go microservice (II) - detailed introduction to protobuf
- C#实现定义一套中间SQL可以跨库执行的SQL语句(案例详解)
- 使用canal配合rocketmq监听mysql的binlog日志
- C # implementation defines a set of SQL statements that can be executed across databases in the middle of SQL (detailed explanation of the case)
- 欧拉函数
- Is Guoyuan futures a regular platform? Is it safe to open an account in Guoyuan futures?
猜你喜欢
如何使用Async-Awati异步任务处理代替BackgroundWorker?
更安全、更智能、更精致,长安Lumin完虐宏光MINI EV?
Lm10 cosine wave homeopathic grid strategy
Online sql to excel (xls/xlsx) tool
Summary and sorting of 8 pits of redis distributed lock
关于判断点是否位于轮廓内的一点思考
用实际例子详细探究OpenCV的轮廓绘制函数drawContours()
FPGA timing constraint sharing 01_ Brief description of the four steps
牛客小白月赛7 谁是神箭手
Explore the contour drawing function drawcontours() of OpenCV in detail with practical examples
随机推荐
Shell programming core technology "four"
In flinksql, in addition to data statistics, is the saved data itself a state
用实际例子详细探究OpenCV的轮廓绘制函数drawContours()
How test engineers "attack the city" (Part 2)
2014 Hefei 31st youth informatics Olympic Games (primary school group) test questions
The kth largest element in the array
2019年蜀山区第十五届青少年信息学竞赛
项目中遇到的线上数据迁移方案1---总体思路整理和技术梳理
牛客小白月赛7 谁是神箭手
Summary and sorting of 8 pits of redis distributed lock
Oracle with as ora-00903: invalid table name multi report error
Unity编辑器扩展C#遍历文件夹以及子目录下的所有图片
生成XML元素
1007 Maximum Subsequence Sum(25 分)(PAT甲级)
求2的n次方
The explain statement in MySQL queries whether SQL is indexed, and several types in extra collate and summarize
FPGA timing constraint sharing 01_ Brief description of the four steps
FPGA时序约束分享01_四大步骤简述
Detailed explanation of the binary processing function threshold() of opencv
HMM隐马尔可夫模型最详细讲解与代码实现