当前位置:网站首页>Good Key, Bad Key (思维,临项交换,经典方法)
Good Key, Bad Key (思维,临项交换,经典方法)
2022-08-02 03:08:00 【lovesickman】
Good Key, Bad Key (思维,临项交换)
题目描述
There are $ n $ chests. The $ i $ -th chest contains $ a_i $ coins. You need to open all $ n $ chests in order from chest $ 1 $ to chest $ n $ .
There are two types of keys you can use to open a chest:
- a good key, which costs $ k $ coins to use;
- a bad key, which does not cost any coins, but will halve all the coins in each unopened chest, including the chest it is about to open. The halving operation will round down to the nearest integer for each chest halved. In other words using a bad key to open chest $ i $ will do $ a_i = \lfloor{\frac{a_i}{2}\rfloor} $ , $ a_{i+1} = \lfloor\frac{a_{i+1}}{2}\rfloor, \dots, a_n = \lfloor \frac{a_n}{2}\rfloor $ ;
- any key (both good and bad) breaks after a usage, that is, it is a one-time use.
You need to use in total $ n $ keys, one for each chest. Initially, you have no coins and no keys. If you want to use a good key, then you need to buy it.
During the process, you are allowed to go into debt; for example, if you have $ 1 $ coin, you are allowed to buy a good key worth $ k=3 $ coins, and your balance will become $ -2 $ coins.
Find the maximum number of coins you can have after opening all $ n $ chests in order from chest $ 1 $ to chest $ n $ .
输入格式
The first line contains a single integer $ t $ ( $ 1 \leq t \leq 10^4 $ ) — the number of test cases.
The first line of each test case contains two integers $ n $ and $ k $ ( $ 1 \leq n \leq 10^5 $ ; $ 0 \leq k \leq 10^9 $ ) — the number of chests and the cost of a good key respectively.
The second line of each test case contains $ n $ integers $ a_i $ ( $ 0 \leq a_i \leq 10^9 $ ) — the amount of coins in each chest.
The sum of $ n $ over all test cases does not exceed $ 10^5 $ .
输出格式
For each test case output a single integer — the maximum number of coins you can obtain after opening the chests in order from chest $ 1 $ to chest $ n $ .
Please note, that the answer for some test cases won’t fit into 32-bit integer type, so you should use at least 64-bit integer type in your programming language (like long long for C++).
样例 #1
样例输入 #1
5
4 5
10 10 3 1
1 2
1
3 12
10 10 29
12 51
5 74 89 45 18 69 67 67 11 96 23 59
2 57
85 60
样例输出 #1
11
0
13
60
58
提示
In the first test case, one possible strategy is as follows:
- Buy a good key for $ 5 $ coins, and open chest $ 1 $ , receiving $ 10 $ coins. Your current balance is $ 0 + 10 - 5 = 5 $ coins.
- Buy a good key for $ 5 $ coins, and open chest $ 2 $ , receiving $ 10 $ coins. Your current balance is $ 5 + 10 - 5 = 10 $ coins.
- Use a bad key and open chest $ 3 $ . As a result of using a bad key, the number of coins in chest $ 3 $ becomes $ \left\lfloor \frac{3}{2} \right\rfloor = 1 $ , and the number of coins in chest $ 4 $ becomes $ \left\lfloor \frac{1}{2} \right\rfloor = 0 $ . Your current balance is $ 10 + 1 = 11 $ .
- Use a bad key and open chest $ 4 $ . As a result of using a bad key, the number of coins in chest $ 4 $ becomes $ \left\lfloor \frac{0}{2} \right\rfloor = 0 $ . Your current balance is $ 11 + 0 = 11 $ .
At the end of the process, you have $ 11 $ coins, which can be proven to be maximal.
我就是不想动脑子的SB
明显有直觉,两种操作有两段性,用邻项交换证明一下就行。
证明之后维护一个前缀和,观察到 /2 ,警觉!观察值域,因为 $log_2{10^9} = 29.xxx $ ,所以时间复杂度 O ( 30 n ) O(30n) O(30n)
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <sstream>
#define pb push_back
#define all(x) (x).begin(),(x).end()
#define mem(f, x) memset(f,x,sizeof(f))
#define fo(i,a,n) for(int i=(a);i<=(n);++i)
#define fo_(i,a,n) for(int i=(a);i<(n);++i)
#define debug(x) cout<<#x<<":"<<x<<endl;
#define endl '\n'
using namespace std;
//#pragma GCC optimize("Ofast,no-stack-protector,unroll-loops,fast-math,O3")
//#pragma GCC target("sse,sse2,sse3,ssse3,sse4,popcnt,abm,mmx,avx,tune=native")
template<typename T>
ostream& operator<<(ostream& os,const vector<T>&v){
for(int i=0,j=0;i<v.size();i++,j++)if(j>=5){
j=0;puts("");}else os<<v[i]<<" ";return os;}
template<typename T>
ostream& operator<<(ostream& os,const set<T>&v){
for(auto c:v)os<<c<<" ";return os;}
template<typename T1,typename T2>
ostream& operator<<(ostream& os,const map<T1,T2>&v){
for(auto c:v)os<<c.first<<" "<<c.second<<endl;return os;}
template<typename T>inline void rd(T &a) {
char c = getchar(); T x = 0, f = 1; while (!isdigit(c)) {
if (c == '-')f = -1; c = getchar();}
while (isdigit(c)) {
x = (x << 1) + (x << 3) + c - '0'; c = getchar();} a = f * x;
}
typedef pair<int,int>PII;
typedef pair<long,long>PLL;
typedef long long ll;
typedef unsigned long long ull;
const int N=2e5+10,M=1e9+7;
ll n,k,m,_;
ll a[N];
void solve(){
cin>>n>>k;
fo(i,1,n)cin>>a[i];
ll sum,ans;
ans = sum = 0;
fo(i,0,n){
ll cnt = 0;
for(int j=i+1;j<=min((int)n,i+31);j++){
ll v = a[j];
v >>= (j-i);
cnt+=v;
}
if(i>=1)
sum += (a[i]-k);
ans = max(sum+cnt,ans);
}
cout<<ans<<endl;
}
int main(){
cin>>_;
while(_--){
solve();
}
return 0;
}
边栏推荐
猜你喜欢
关于#sql#的问题:该怎么写sql语句,
Foundry教程:使用多种方式编写可升级的智能代理合约(下)
ROS2自学笔记:launch文件完整编写流程
EF Core:基于关系的复杂查询 区分IEnumerable和IQueryable
第七周复习
mysql使用on duplicate key update批量更新数据
Hit the programmer interview scene: What did Baidu interviewers ask me?
iVX低代码平台系列详解 -- 概述篇(二)
aws s3 upload file
svm.SVC application practice 1--Breast cancer detection
随机推荐
VPS8505 微功率隔离电源隔离芯片 2.3-6V IN /24V/1A 功率管
Kubernetes 基本概念
2022年最新一篇文章教你青龙面板拉库,拉取单文件,安装依赖,设置环境变量,解决没有或丢失依赖can‘t find module之保姆教程(附带几十个青龙面板脚本仓库)
第一章——线性表(顺序表和链表)
VPS8504C 微功率隔离电源隔离芯片 VPSC源特科技
第七周复习
一种基于行为空间的回声状态网络参数优化方法
MySQL八股文背诵版
Go简单实现协程池
Nacos source code analysis topic (1) - environment preparation
MySQL8.0.26 installation and configuration tutorial (windows 64-bit)
有人知道HTML怎么到MYSQL数据库吗? (NODEJS)
第二章——堆栈、队列
centos安装mysql8
C语言力扣第47题全排列 II。搜索回溯
两对象数组比较拿出不同值方法
知识体系树
[Daily LeetCode]——1. The sum of two numbers
iVX低代码平台系列详解 -- 概述篇(二)
MySQL8 -- use msi (graphical user interface) under Windows installation method