当前位置:网站首页>3n+1问题
3n+1问题
2022-08-03 05:10:00 【-JMY-】
题目描述
•对于任意大于1的自然数n,若n为奇数,则将n变为3n+1,否则变为n的一半。经过若干次这样的变换,一定会使n变为1。例如3→10 →5 →16 →8 →4 →2 →1。
•1<n<=2147483647
•输入n,输出变换过程,每个数后面输出一个空格。
•例如,输入3,输出
•3 10 5 16 8 4 2 1
样例输入
3
样例输出
3 10 5 16 8 4 2 1
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
long long a;
cin>>a;
while(a!=1){
cout<<a<<' ';
if(a%2==1)
a=a*3+1;
else
a/=2;
}
cout<<1<<' ';
}
边栏推荐
猜你喜欢
Interface Test Framework Practice | Process Encapsulation and Test Case Design Based on Encrypted Interface
Online password generator tool recommendation
Pr第二次培训笔记
web安全-SSTI模板注入漏洞
Kaggle 入门(Kaggle网站使用及项目复现)
13.< tag-动态规划和回文字串>lt.647. 回文子串 + lt.516.最长回文子序列
CAD有生僻字如何打出来、如何提交软件相关问题或建议?
js implements a bind function
Harmony OS Date ano UI 】 【 】 the basic operation
Harmony OS ets ArkUI 】 【 】 the development basic page layout and data connection
随机推荐
typescript45-接口之间的兼容性
1. 两数之和
[Fine talk] Using native js to implement todolist
阿里云对象存储oss私有桶生成链接
Super handy drawing tool is recommended
typescript41-class类的私有修饰符
Unity2D horizontal board game tutorial 6 - enemy AI and attack animation
vim命令
Talking about GIS Data (6) - Projected Coordinate System
Junit
数据分析 第一篇
typescript49-交叉类型
用scikit-learn学习谱聚类
Shell conditional statement judgment
《录取通知》 观后感
Ali cloud object storage oss private barrels to generate links
ModelArts第二次培训
4.如何避免缓存穿透、缓存击穿、缓存雪崩
1089 狼人杀-简单版 (20 分)
GIS数据漫谈(五)— 地理坐标系统