当前位置:网站首页>1060 爱丁顿数 (25 分)
1060 爱丁顿数 (25 分)
2022-08-03 05:09:00 【破烂摆烂人】
英国天文学家爱丁顿很喜欢骑车。据说他为了炫耀自己的骑车功力,还定义了一个“爱丁顿数” E ,即满足有 E 天骑车超过 E 英里的最大整数 E。据说爱丁顿自己的 E 等于87。
现给定某人 N 天的骑车距离,请你算出对应的爱丁顿数 E(≤N)。
输入格式:
输入第一行给出一个正整数 N (≤10
5
),即连续骑车的天数;第二行给出 N 个非负整数,代表每天的骑车距离。
输出格式:
在一行中给出 N 天的爱丁顿数。
输入样例:
10
6 7 6 9 3 10 8 2 7 8
输出样例:
6
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int cmp(const void *a, const void *b) {
return *(int *)b - *(int *)a;//降序
}
int main(int argc, char *argv[]) {
int n ;
scanf("%d",&n) ;
int a[100000] ;
int i , j ;
int cnt = 0 , tmp;
for( i = 0 ; i < n ; i++ ){
scanf("%d",&a[i]) ;
}
qsort(a,n,sizeof(int),cmp) ;
for( i = 0 ; i < n ; i++ ){
if( i+1 < a[i] ){
cnt++ ;
}
}
printf("%d",cnt) ;
return 0;
}
边栏推荐
- 三丁基-巯基膦烷「tBuBrettPhos Pd(allyl)」OTf),1798782-17-8
- 【Harmony OS】【ArkUI】ets开发 图形与动画绘制
- [Fine talk] Using native js to implement todolist
- Interface test Mock combat (2) | Combined with jq to complete batch manual Mock
- Where is the value of testers
- 传统企业如何转型社交电商,泰山众筹的玩法有哪些?
- 接口测试框架实战(一) | Requests 与接口请求构造
- Online password generator tool recommendation
- User password encryption tool
- 接口测试框架实战(四)| 搞定 Schema 断言
猜你喜欢
Tag stack - stack monotonically preparatory knowledge - lt. 739. The daily temperature
Secondary development of WinForm controls
Apache DolphinScheduler版本2.0.5分布式集群的安装
typescript47-函数之间的类型兼容性
打破传统电商格局,新型社交电商到底有什么优点?
社交电商:流量红利已尽,裂变营销是最低成本的获客之道
typescript41-class类的私有修饰符
Shell conditional statement judgment
DDL操作数据库、表、列
GIS数据漫谈(六)— 投影坐标系统
随机推荐
【HMS core】【Ads Kit】Huawei Advertising——Overseas applications are tested in China. Official advertisements cannot be displayed
内部类、static关键字、final
JS bottom handwriting
BIOTIN ALKYNE CAS: 773888-45-2 Price, Supplier
Interface test Mock combat (2) | Combined with jq to complete batch manual Mock
DFS's complement to pruning
社交电商:链动2+1模式,为什么能在电商行业生存那么久?
Exception(异常) 和 Error(错误)区别解析
2022/08/02 学习笔记 (day22) 多线程
Where is the value of testers
c语言结构体中的冒泡排序
Peptides mediated PEG DSPE of phospholipids, targeted functional materials - PEG - RGD/TAT/NGR/APRPG
typescript43-类型兼容性说明
Common fluorescent dyes to modify a variety of groups and its excitation and emission wavelength data in the data
Tag stack - stack monotonically preparatory knowledge - lt. 739. The daily temperature
建立树形结构
链动2+1模式简单,奖励结构丰厚,自主裂变?
设计模式——组合模式、享元模式(Integer缓存)(结构型模式)
【Harmony OS】【FAQ】Hongmeng Questions Collection 1
接口和抽象