当前位置:网站首页>1003 emergency (25 points) (PAT class a)
1003 emergency (25 points) (PAT class a)
2022-07-04 19:36:00 【Acacia moon tower】
Problem Description:
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
I typed it according to the boss' blog ,,https://www.liuchuo.net/archives/2359
#include <iostream>
#include <algorithm>
using namespace std;
int n, m, c1, c2;
int e[510][510], weight[510], dis[510], num[510], w[510];
bool visit[510];
const int inf = 999999;
int main() {
scanf("%d %d %d %d", &n, &m, &c1, &c2);
for(int i = 0; i < n; i++) {
scanf("%d", &weight[i]);
}
fill(e[0], e[0]+510*510, inf);
fill(dis, dis+510, inf);
int x, y, v;
for(int i = 0; i < m; i++) {
scanf("%d %d %d", &x, &y, &v);
e[x][y] = e[y][x] = v;
}
dis[c1] = 0;
w[c1] = weight[c1];
num[c1] = 1;
for(int i = 0; i < n; i++) {
int u = -1, minn = inf;
for(int j = 0; j < n; j++) {
if(visit[j] == false && dis[j] < minn) {
u = j;
minn = dis[j];
}
}
if(u == -1) break;
visit[u] = true;
for(int v = 0; v < n; v++) {
if(visit[v] == false && e[u][v] != inf) {
if(dis[u] + e[u][v] < dis[v]) {
dis[v] = dis[u] + e[u][v];
num[v] = num[u];
w[v] = w[u] + weight[v];
} else if(dis[u] + e[u][v] == dis[v]) {
num[v] = num[v] + num[u];
if(w[u] + weight[v] > w[v]) {
w[v] = w[u] + weight[v];
}
}
}
}
}
printf("%d %d\n", num[c2], w[c2]);
return 0;
}
边栏推荐
- PointNeXt:通过改进的模型训练和缩放策略审视PointNet++
- Add namespace declaration
- Stream流
- 1007 Maximum Subsequence Sum(25 分)(PAT甲级)
- FPGA时序约束分享01_四大步骤简述
- prometheus安装
- There are multiple divs in the large div, which are displayed on the same line. After overflow, scroll bars are generated without line breaks
- 1672. 最富有客户的资产总量
- 2021 Hefei informatics competition primary school group
- TCP两次挥手,你见过吗?那四次握手呢?
猜你喜欢
BCG 使用之CBCGPProgressDlg进度条使用
在线SQL转Excel(xls/xlsx)工具
FPGA timing constraint sharing 01_ Brief description of the four steps
Master the use of auto analyze in data warehouse
92.(cesium篇)cesium楼栋分层
Pytorch学习(四)
Hough transform Hough transform principle
TCP两次挥手,你见过吗?那四次握手呢?
node_ Exporter deployment
LeetCode第300场周赛(20220703)
随机推荐
Stream流
The 300th weekly match of leetcode (20220703)
Educational Codeforces Round 22 E. Army Creation
Introduction to polyfit software
FPGA时序约束分享01_四大步骤简述
Hough Transform 霍夫变换原理
Stream stream
ftp、sftp文件传输
PolyFit软件介绍
牛客小白月赛7 F题
Qt实现界面滑动切换效果
OpenCV的二值化处理函数threshold()详解
Shell 编程核心技术《三》
FTP, SFTP file transfer
牛客小白月赛7 E Applese的超能力
PointNeXt:通过改进的模型训练和缩放策略审视PointNet++
BCG 使用之CBCGPProgressDlgCtrl进度条使用
Jetpack Compose 教程
Oracle with as ORA-00903: invalid table name 多表报错
关于判断点是否位于轮廓内的一点思考