当前位置:网站首页>HDU 6440 2018中国大学生程序设计网络选拔赛
HDU 6440 2018中国大学生程序设计网络选拔赛
2022-07-04 17:59:00 【相思明月楼】
Problem Description
Freshmen frequently make an error in computing the power of a sum of real numbers, which usually origins from an incorrect equation (m+n)p=mp+np, where m,n,p are real numbers. Let's call it ``Beginner's Dream''.
For instance, (1+4)2=52=25, but 12+42=17≠25. Moreover, 9+16−−−−−√=25−−√=5, which does not equal 3+4=7.
Fortunately, in some cases when p is a prime, the identity
(m+n)p=mp+np
holds true for every pair of non-negative integers m,n which are less than p, with appropriate definitions of addition and multiplication.
You are required to redefine the rules of addition and multiplication so as to make the beginner's dream realized.
Specifically, you need to create your custom addition and multiplication, so that when making calculation with your rules the equation (m+n)p=mp+np is a valid identity for all non-negative integers m,n less than p. Power is defined as
ap={1,ap−1⋅a,p=0p>0
Obviously there exists an extremely simple solution that makes all operation just produce zero. So an extra constraint should be satisfied that there exists an integer q(0<q<p) to make the set {qk|0<k<p,k∈Z} equal to {k|0<k<p,k∈Z}. What's more, the set of non-negative integers less than p ought to be closed under the operation of your definitions.
Hint
Hint for sample input and output:
From the table we get 0+1=1, and thus (0+1)2=12=1⋅1=1. On the other hand, 02=0⋅0=0, 12=1⋅1=1, 02+12=0+1=1.
They are the same.
Input
The first line of the input contains an positive integer T(T≤30) indicating the number of test cases.
For every case, there is only one line contains an integer p(p<210), described in the problem description above. p is guranteed to be a prime.
Output
For each test case, you should print 2p lines of p integers.
The j-th(1≤j≤p) integer of i-th(1≤i≤p) line denotes the value of (i−1)+(j−1). The j-th(1≤j≤p) integer of (p+i)-th(1≤i≤p) line denotes the value of (i−1)⋅(j−1).
Sample Input
1
2
Sample Output
0 1
1 0
0 0
0 1
#include <iostream>
#include <stdio.h>
using namespace std;
int main() {
int t, p;
scanf("%d", &t);
while(t--) {
scanf("%d", &p);
for(int i = 1; i <= p; i++) {
for(int j = 1; j <= p; j++) {
j==p?printf("%d\n", ((i-1)+(j-1))%p):printf("%d ", ((i-1)+(j-1))%p);
}
}
for(int i = 1; i <= p; i++) {
for(int j = 1; j <= p; j++) {
j==p?printf("%d\n", ((i-1)*(j-1))%p):printf("%d ", ((i-1)*(j-1))%p);
}
}
}
return 0;
}
边栏推荐
- 添加命名空间声明
- 大div中有多个div,这些div在同一行显示,溢出后产生滚动条而不换行
- 如何使用Async-Awati异步任务处理代替BackgroundWorker?
- Qt实现界面滑动切换效果
- 勾股数规律(任意三个数能够满足勾股定理需要满足的条件)
- .NET ORM框架HiSql实战-第二章-使用Hisql实现菜单管理(增删改查)
- 用实际例子详细探究OpenCV的轮廓绘制函数drawContours()
- How to use async Awati asynchronous task processing instead of backgroundworker?
- Jetpack Compose 教程
- 生成XML元素
猜你喜欢
Online sql to excel (xls/xlsx) tool
There are multiple divs in the large div, which are displayed on the same line. After overflow, scroll bars are generated without line breaks
PolyFit软件介绍
Summary and sorting of 8 pits of redis distributed lock
Lm10 cosine wave homeopathic grid strategy
The latest progress of Intel Integrated Optoelectronics Research promotes the progress of CO packaging optics and optical interconnection technology
Hough transform Hough transform principle
性能优化之关键渲染路径
OpenCV的二值化处理函数threshold()详解
[uniapp] uniapp development app online Preview PDF file
随机推荐
牛客小白月赛7 I 新建 Microsoft Office Word 文档
Oracle with as ora-00903: invalid table name multi report error
Opencv functions and methods related to binary threshold processing are summarized for comparison and use
QT realizes interface sliding switching effect
Caché WebSocket
876. 链表的中间结点
Using SSH
Crawler (6) - Web page data parsing (2) | the use of beautifulsoup4 in Crawlers
如何使用Async-Awati异步任務處理代替BackgroundWorker?
Upgrade the smart switch, how much is the difference between the "zero fire version" and "single fire" wiring methods?
安徽 中安在线文旅频道推出“跟着小编游安徽”系列融媒体产品
Introduction to polyfit software
mysql中explain语句查询sql是否走索引,extra中的几种类型整理汇总
ftp、sftp文件传输
redis分布式锁的8大坑总结梳理
1672. Total assets of the richest customers
In flinksql, in addition to data statistics, is the saved data itself a state
Go微服务(二)——Protobuf详细入门
[release] a tool for testing WebService and database connection - dbtest v1.0
FPGA时序约束分享01_四大步骤简述