当前位置:网站首页>1038 Recover the Smallest Number
1038 Recover the Smallest Number
2022-07-03 00:24:00 【Brosto_Cloud】
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
自定义排序函数:
当两个字符串不是一个是另一个的前缀这种情况时,直接按升序排序;
当一个是另一个的前缀时:取长度大的字符串前缀后的第一个字符(即当短的字符串长度为length时,取长字符串的s[length])将它与短字符串的第一个字符对比,更小的放在前面;
这样可以保证每两个字符串之间的顺序一定是两种排列顺序中使组成的数更小的那个。
排序后按新的顺序组成答案字符串,注意去掉前导零,注意答案为0的情况。
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
string a[10010];
bool cmp(string s1, string s2) {
int length = min(s1.size(), s2.size());
for (int i = 0; i < length; i++) {
if (s1[i] != s2[i]) {
return s1 < s2;
}
}
if (s1.size() < s2.size()) {
if (s2[length] > s1[0]) {
return true;
} else {
return false;
}
} else {
if (s1[length] > s2[0]) {
return false;
} else {
return true;
}
}
}
int main() {
int n;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a[i];
}
sort(a, a + n, cmp);
bool flag = 0;
string ans = "";
for (int i = 0; i < n; i++) {
ans += a[i];
}
for (int i = 0; i < ans.size(); i++) {
if (ans[i] != '0') {
flag = 1;
}
if (flag) {
cout << ans[i];
}
}
if (flag == 0) {
cout << 0;
}
return 0;
}
边栏推荐
- How to find out the currently running version of Solr- How do I find out version of currently running Solr?
- Array and collection performance comparison
- 2022中国3D视觉企业(引导定位、分拣场景)厂商名单
- Logback configuration file
- RK3568开发板评测篇(二):开发环境搭建
- 百度智能云牵头打造智能云综合标准化平台
- tail -f 、tail -F、tailf的区别
- File operation io-part2
- 【AutoSAR 二 AppL概述】
- Helm basic learning
猜你喜欢
瑞萨RZ/G2L 处理器简介|框架图|功耗|原理图及硬件设计指南
【AutoSAR 四 BSW概述】
这不平凡的两年,感谢我们一直在一起!
2022中国3D视觉企业(引导定位、分拣场景)厂商名单
【爱死机】《吉巴罗》被忽略的细节
文件操作IO-Part2
[AUTOSAR nine c/s principle Architecture]
飞凌搭载TI AM62x的ARM核心板/开发板首发上市,亮相Embedded World 2022
tail -f 、tail -F、tailf的区别
Hundreds of continuous innovation to create free low code office tools
随机推荐
【AutoSAR 十一 通信相关机制】
【AutoSAR 二 AppL概述】
【AutoSAR 四 BSW概述】
全志A40i/T3如何通过SPI转CAN
Initial order of pointer (basic)
Win10 can't be installed in many ways Problems with NET3.5
【案例分享】让新时代教育发展与“数”俱进
leetcode-241:为运算表达式设计优先级
[AUTOSAR VI description document]
深度剖析数据在内存中的存储
基于ARM RK3568的红外热成像体温检测系统
University of Oslo: Li Meng | deep reinforcement learning based on swing transformer
1.11 - 总线
1.12 - Instructions
[AUTOSAR XIII NVM]
Array and collection performance comparison
[AUTOSAR 11 communication related mechanism]
【AutoSAR 九 C/S原理架构】
Attributeerror: 'tuple' object has no attribute 'layer' problem solving
【日常训练】871. 最低加油次数