当前位置:网站首页>PAT甲级:1038 Recover the Smallest Number
PAT甲级:1038 Recover the Smallest Number
2022-08-04 13:06:00 【正在黑化的KS】
题目描述:
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
代码长度限制
16 KB
时间限制
200 ms
内存限制
64 MB
题目大意:
题⽬⼤意:给⼀些字符串,求它们拼接起来构成最⼩数字的⽅式
解题思路:
贪心
用 a + b < b + a 来判断a和b两个字符串的前后位置
Python3代码:
import functools
lst = list(input().split())
N = int(lst[0]) ; lst = lst[1:]
def cmp(a,b) : # 自定义排序函数
if a + b < b + a : return -1
elif a + b == b + a : return 0
else : return 1
lst.sort(key=functools.cmp_to_key(cmp))
ans = "".join(lst)
print(int(ans))
边栏推荐
- 面试官:说一下NIO和BIO的区别
- RobotFramework二次开发(一)
- Matlab记录
- 汉诺塔怎么玩
- “蔚来杯“2022牛客暑期多校训练营2 G、J、K
- MFC的相机双目标定界面设计
- "Lonely Walking on the Moon" is a powerful medicine, it can't cure the internal friction of happy twist
- Why don't young people like to buy Mengniu and Yili?
- Motion Regulations (18) - and check the basic questions - gang
- Two years of independent development experience Programmers tell us the experience of making money (listen to the masters who really make money)
猜你喜欢
“蔚来杯“2022牛客暑期多校训练营5 B、C、F、G、H、K
项目里的各种配置,你都了解吗?
LeetCode_424_替换后的最长重复字符
漏洞复现 - - - Alibaba Nacos权限认证绕过
基于双层共识控制的直流微电网优化调度(Matlab代码实现)
03 多线程与高并发 - ReentrantLock 源码解析
代码越写越乱?那是因为你没用责任链!
持续交付(二)PipeLine基本使用
[UML] Summary of Information System Analysis and Design Knowledge Points
[Niu Ke brush questions-SQL big factory interview questions] NO5. Analysis of a treasure store (e-commerce model)
随机推荐
封装、继承、多态的联合使用实现不同等级学生分数信息的统计
【PHP实现微信公众平台开发—基础篇】第2章 微信公众账号及申请流程详解
基于双层共识控制的直流微电网优化调度(Matlab代码实现)
sqlserver删除重复数据
正确使用Impala的invalidate metadata与refresh语句
“蔚来杯“2022牛客暑期多校训练营2 G、J、K
redisTemplate存取List遇到的坑
JSX使用
Niuke.com Brush Question Record || Linked List
router---mode
一分钟认识 IndexedDB 数据库,太强大了!
从零开始配置 vim(7)——自动命令
未来已来,只是尚未流行
Why is Luo Zhenyu's A-share dream so difficult to fulfill?
Do you understand the various configurations in the project?
手搓一个“七夕限定”,用3D Engine 5分钟实现烟花绽放效果
How to stress the MySQL performance indicators TPS\QPS\IOPS?
Control CD-ROM with VbScript
03 多线程与高并发 - ReentrantLock 源码解析
Just a Hook