当前位置:网站首页>简单排序(暑假每日一题 14)
简单排序(暑假每日一题 14)
2022-08-04 01:37:00 【sweetheart7-7】
给定一个包含 n n n 个整数的数组,请你删除数组中的重复元素并将数组从小到大排序后输出。
输入格式
第一行包含一个整数 n n n。
第二行包含 n n n 个不超过 1000 1000 1000 的正整数。
输出格式
输出去重和排序完毕后的数组。
数据范围
1 ≤ n ≤ 1000 1≤n≤1000 1≤n≤1000
输入样例:
6
8 8 7 3 7 7
输出样例:
3 7 8
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 1010;
int n;
int a[N];
int main(){
cin >> n;
for(int i = 0; i < n; i++)
cin >> a[i];
sort(a, a + n);
n = unique(a, a + n) - a;
for(int i = 0; i < n; i++)
cout << a[i] << ' ';
return 0;
}
边栏推荐
- 循环绕过问题
- 持续投入商品研发,叮咚买菜赢在了供应链投入上
- 网络带宽监控,带宽监控工具哪个好
- 优秀的测试/开发程序员,是怎样修炼的?步步为营地去执行......
- esp32发布机器人电池电压到ros2(micro-ros+CoCube)
- 【Untitled】
- Android interview questions and answer analysis of major factories in the first half of 2022 (continuously updated...)
- 持续投入商品研发,叮咚买菜赢在了供应链投入上
- 【虚拟化生态平台】虚拟化平台esxi挂载USB硬盘
- Installation and configuration of nodejs+npm
猜你喜欢
Vant3 - click on the corresponding name name to jump to the next page corresponding to the location of the name of the TAB bar
TensoFlow学习记录(二):基础操作
Use of lombok annotation @RequiredArgsConstructor
typescript51 - basic use of generics
redis中常见的问题(缓存穿透,缓存雪崩,缓存击穿,redis淘汰策略)
Continuing to invest in product research and development, Dingdong Maicai wins in supply chain investment
一个注解替换synchronized关键字:分布式场景下实现方法加锁
The idea of the diagram
字符串的排列
this巩固训练,从两道执行题加深理解闭包与箭头函数中的this
随机推荐
【日志框架】
esp32发布机器人电池电压到ros2(micro-ros+CoCube)
typescript56 - generic interface
C 学生管理系统_添加学生
持续投入商品研发,叮咚买菜赢在了供应链投入上
js中常用的几种遍历处理数据的方法梳理
Sticker Spelling - Memory Search / Shape Pressure DP
typescript55 - generic constraints
实例041:类的方法与变量
[store mall project 01] environment preparation and testing
Use of lombok annotation @RequiredArgsConstructor
this巩固训练,从两道执行题加深理解闭包与箭头函数中的this
循环绕过问题
实例038:矩阵对角线之和
Continuing to invest in product research and development, Dingdong Maicai wins in supply chain investment
Demand analysis of MES management system in electronic assembly industry
nodejs 安装多版本 版本切换
Hey, I had another fight with HR in the small group!
How to copy baby from Taobao (or Tmall store) through API interface to Pinduoduo interface code docking tutorial
通用的测试用例编写大全(登录测试/web测试等)