当前位置:网站首页>HDU 1097 A hard puzzle

HDU 1097 A hard puzzle

2022-07-04 19:37:00 Acacia moon tower

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b's last digit number.

Sample Input

7 66

8 800

Sample Output

9

6

Answer key : This is a regular problem , The last number of each number changes periodically .

#include <iostream>
using namespace std;
typedef long long ll;
int main() {
	ll a, b;
	int ans[][5] = {
   {0},{1},{2,4,8,6},{3,9,7,1},{4,6},{5},{6},{7,9,3,1},{8,4,2,6},{9,1}};
	while(cin>>a>>b) {
		a %= 10;
		if(a==0||a==1||a==5||a==6) {
			cout<<ans[a][0]<<endl;
		} else if(a==4||a==9) {
			if(b%2==0) {
				cout<<ans[a][1]<<endl;
			} else {
				cout<<ans[a][(b%2)-1]<<endl;
			}
		} else if(a==2||a==3||a==7||a==8) {
			if(b%4==0) {
				cout<<ans[a][3]<<endl;
			} else {
				cout<<ans[a][(b%4)-1]<<endl;
			}
		}
	}
	return 0;
}

 

原网站

版权声明
本文为[Acacia moon tower]所创,转载请带上原文链接,感谢
https://yzsam.com/2022/185/202207041758484665.html