当前位置:网站首页>1011 World Cup Betting (20 分)(PAT甲级)
1011 World Cup Betting (20 分)(PAT甲级)
2022-07-04 17:58:00 【相思明月楼】
Problem Description:
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W
for win, T
for tie, and L
for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
For example, 3 games' odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W
for the 3rd game, T
for the 2nd game, and T
for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W
, T
and L
.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31
题意:分别找出每一行中的最大值,然后求值。
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
double fmax(double a, double b, double c) {
double t = max(a, b);
return max(t, c);
}
int main() {
double w, t, l, ans = 1;
int k = 0;
char e[5];
for(int i = 0; i < 3; i++) {
scanf("%lf %lf %lf", &w, &t, &l);
if(fmax(w,t,l) == w) {
e[k++] = 'W';
ans *= w;
} else if(fmax(w,t,l) == t){
e[k++] = 'T';
ans *= t;
} else {
e[k++] = 'L';
ans *= l;
}
}
ans = (ans*0.65-1)*2;
for(int i = 0; i < k; i++) {
printf("%c ", e[i]);
}
printf("%.2lf\n", ans);
return 0;
}
边栏推荐
- Wechat reading notes of "work, consumerism and the new poor"
- 生成XML元素
- IBM WebSphere MQ retrieving messages
- The latest progress of Intel Integrated Optoelectronics Research promotes the progress of CO packaging optics and optical interconnection technology
- 整理混乱的头文件,我用include what you use
- 添加命名空间声明
- Using FTP
- Shell 编程核心技术《一》
- 自由小兵儿
- Guys, for help, I use MySQL CDC 2.2.1 (Flink 1.14.5) to write Kafka and set
猜你喜欢
随机推荐
生成XML元素
长城证券开户安全吗 买股票怎么开户
FPGA时序约束分享01_四大步骤简述
YOLOv5s-ShuffleNetV2
英特尔集成光电研究最新进展推动共封装光学和光互连技术进步
Is the securities account opened by qiniu safe?
SSL证书续费相关问题详解
Using SSH
Caché WebSocket
[uniapp] uniapp development app online Preview PDF file
从实时应用角度谈通信总线仲裁机制和网络流控
Unity adds a function case similar to editor extension to its script, the use of ContextMenu
Technologie de base de la programmation Shell IV
Shell 編程核心技術《四》
Generate XML elements
Stream流
To sort out messy header files, I use include what you use
Unity给自己的脚本添加类似编辑器扩展的功能案例ContextMenu的使用
Guys, for help, I use MySQL CDC 2.2.1 (Flink 1.14.5) to write Kafka and set
Using FTP