当前位置:网站首页>1011 World Cup Betting (20 分)(PAT甲级)
1011 World Cup Betting (20 分)(PAT甲级)
2022-07-04 17:58:00 【相思明月楼】
Problem Description:
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W
for win, T
for tie, and L
for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
For example, 3 games' odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W
for the 3rd game, T
for the 2nd game, and T
for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W
, T
and L
.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31
题意:分别找出每一行中的最大值,然后求值。
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
double fmax(double a, double b, double c) {
double t = max(a, b);
return max(t, c);
}
int main() {
double w, t, l, ans = 1;
int k = 0;
char e[5];
for(int i = 0; i < 3; i++) {
scanf("%lf %lf %lf", &w, &t, &l);
if(fmax(w,t,l) == w) {
e[k++] = 'W';
ans *= w;
} else if(fmax(w,t,l) == t){
e[k++] = 'T';
ans *= t;
} else {
e[k++] = 'L';
ans *= l;
}
}
ans = (ans*0.65-1)*2;
for(int i = 0; i < k; i++) {
printf("%c ", e[i]);
}
printf("%.2lf\n", ans);
return 0;
}
边栏推荐
猜你喜欢
LeetCode第300场周赛(20220703)
The latest progress of Intel Integrated Optoelectronics Research promotes the progress of CO packaging optics and optical interconnection technology
Pointnet/Pointnet++点云数据集处理并训练
性能优化之关键渲染路径
To sort out messy header files, I use include what you use
神经网络物联网平台搭建(物联网平台搭建实战教程)
与二值化阈值处理相关的OpenCV函数、方法汇总,便于对比和拿来使用
YOLOv5s-ShuffleNetV2
Go microservice (II) - detailed introduction to protobuf
OpenCV的二值化处理函数threshold()详解
随机推荐
信息学奥赛一本通 1336:【例3-1】找树根和孩子
神经网络物联网应用技术就业前景【欢迎补充】
sqlserver的CDC第一次查询的能读取到数据,但后面增删改读取不到,是什么原因
建立自己的网站(15)
Cache é JSON uses JSON adapters
Shell programming core technology "three"
数组中的第K个最大元素
Using SSH
Pytest 可视化测试报告之 Allure
876. Intermediate node of linked list
关于判断点是否位于轮廓内的一点思考
请教一下 flinksql中 除了数据统计结果是状态被保存 数据本身也是状态吗
Nebula importer data import practice
Other InterSystems%net tools
[uniapp] uniapp development app online Preview PDF file
神经网络物联网应用技术学什么
Process of manually encrypt the mass-producing firmware and programming ESP devices
Oracle with as ORA-00903: invalid table name 多表报错
IBM WebSphere MQ检索邮件
函数式接口