当前位置:网站首页>P1996 约瑟夫问题
P1996 约瑟夫问题
2022-08-03 22:51:00 【Recursi】
题目描述
n n n 个人围成一圈,从第一个人开始报数,数到 m m m 的人出列,再由下一个人重新从 1 1 1 开始报数,数到 m m m 的人再出圈,依次类推,直到所有的人都出圈,请输出依次出圈人的编号。
注意:本题和《深入浅出-基础篇》上例题的表述稍有不同。书上表述是给出淘汰 n − 1 n-1 n−1 名小朋友,而该题是全部出圈。
输入格式
输入两个整数 n , m n,m n,m。
输出格式
输出一行 n n n 个整数,按顺序输出每个出圈人的编号。
样例 #1
样例输入 #1
10 3
样例输出 #1
3 6 9 2 7 1 8 5 10 4
提示
1 ≤ m , n ≤ 100 1 \le m, n \le 100 1≤m,n≤100
/* * @Description: To iterate is human, to recurse divine. * @Autor: Recursion * @Date: 2022-08-02 20:21:04 * @LastEditTime: 2022-08-02 21:29:25 */
#include <bits/stdc++.h>
#define LL long long
using namespace std;
const int maxn = 1e6 + 10;
const int mod = 1e9 + 7;
const int INF = 1e9 + 10;
const int N = 1e6;
int n,m;
bool a[N];
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
int n;
int pos = 0;
cin >> n >> m;
for(int i = 1;i <= n;i ++){
for(int j = 1;j <= m; j++){
pos ++;
if(pos> n)
pos = 1;
if(a[pos]==1){
j--;
}
}
cout << pos << " ";
a[pos] = 1;
}
return 0;
}
/* * @Description: To iterate is human, to recurse divine. * @Autor: Recursion * @Date: 2022-08-02 21:40:07 * @LastEditTime: 2022-08-02 21:45:02 */
#include <bits/stdc++.h>
#define LL long long
using namespace std;
const int maxn = 1e6 + 10;
const int mod = 1e9 + 7;
const int INF = 1e9 + 10;
const int N = 1e6;
int n,m;
queue<int> q;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
cin >> n >> m;
int num = 1;
for(int i = 1;i <= n;i ++)
q.push(i);
while(!q.empty()){
if(num == m){
cout << q.front() << " ";
q.pop();
num = 1;
}
else{
num++;
q.push(q.front());//排至队尾
q.pop();
}
}
return 0;
}
边栏推荐
- 目标检测的国内外研究现状
- Basic Concepts of Graphs
- LabVIEW code generation error 61056
- start with connect by implements recursive query
- 授人以渔 - 如何自行查询任意 SAP UI5 控件属性的文档和技术实现细节试读版
- 2022-08-02 mysql/stonedb慢SQL-Q18-内存使用暴涨分析
- Cisco ike2 IPSec configuration
- Embedded Systems: Clocks
- PowerMockup 4.3.4::::Crack
- 使用tf.image.resize() 和tf.image.resize_with_pad()调整图像大小
猜你喜欢
What is Adobe?
最小化安装debian11
Cisco ike2 IPSec configuration
BMN: Boundary-Matching Network for Temporal Action Proposal Generation Reading Notes
Summary bug 】 【 Elipse garbled solution project code in Chinese!
HCIP BGP lab report
ML's yellowbrick: A case of interpretability (threshold map) for LoR logistic regression model using yellowbrick based on whether Titanic was rescued or not based on the two-class prediction dataset
Software testing is seriously involution, how to improve your competitiveness?
113. Teach a Man how to fish - How to query the documentation and technical implementation details of any SAP UI5 control property by yourself
What is the difference between the generator version and the viewer version?
随机推荐
HCIP BGP lab report
《数字经济全景白皮书》金融数字用户篇 重磅发布!
UVa 437 - The Tower of Babylon (White Book)
Fluorescein-PEG-CLS,胆固醇-聚乙二醇-荧光素科研试剂
Summary bug 】 【 Elipse garbled solution project code in Chinese!
软测人每个阶段的薪资待遇,快来康康你能拿多少?
UVa 10003 - Cutting Sticks (White Book, Interval DP)
Click the icon in Canvas App to generate PDF and save it to Dataverse
Kotlin - extension functions and operator overloading
How to write a database document management tool based on WPF (2)
Testng listener
目标检测的国内外研究现状
[MySQL Advanced] Creation and Management of Databases and Tables
完全二叉树问题
Another MySQL masterpiece published by Glacier (send the book at the end of the article)!!
noip初赛
node连接mysql数据库报错:Client does not support authentication protocol requested by server
冰河又一MySQL力作出版(文末送书)!!
ML's yellowbrick: A case of interpretability (threshold map) for LoR logistic regression model using yellowbrick based on whether Titanic was rescued or not based on the two-class prediction dataset
二叉搜索树解决落叶问题