当前位置:网站首页>P1996 约瑟夫问题
P1996 约瑟夫问题
2022-08-03 22:51:00 【Recursi】
题目描述
n n n 个人围成一圈,从第一个人开始报数,数到 m m m 的人出列,再由下一个人重新从 1 1 1 开始报数,数到 m m m 的人再出圈,依次类推,直到所有的人都出圈,请输出依次出圈人的编号。
注意:本题和《深入浅出-基础篇》上例题的表述稍有不同。书上表述是给出淘汰 n − 1 n-1 n−1 名小朋友,而该题是全部出圈。
输入格式
输入两个整数 n , m n,m n,m。
输出格式
输出一行 n n n 个整数,按顺序输出每个出圈人的编号。
样例 #1
样例输入 #1
10 3
样例输出 #1
3 6 9 2 7 1 8 5 10 4
提示
1 ≤ m , n ≤ 100 1 \le m, n \le 100 1≤m,n≤100
/* * @Description: To iterate is human, to recurse divine. * @Autor: Recursion * @Date: 2022-08-02 20:21:04 * @LastEditTime: 2022-08-02 21:29:25 */
#include <bits/stdc++.h>
#define LL long long
using namespace std;
const int maxn = 1e6 + 10;
const int mod = 1e9 + 7;
const int INF = 1e9 + 10;
const int N = 1e6;
int n,m;
bool a[N];
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
int n;
int pos = 0;
cin >> n >> m;
for(int i = 1;i <= n;i ++){
for(int j = 1;j <= m; j++){
pos ++;
if(pos> n)
pos = 1;
if(a[pos]==1){
j--;
}
}
cout << pos << " ";
a[pos] = 1;
}
return 0;
}
/* * @Description: To iterate is human, to recurse divine. * @Autor: Recursion * @Date: 2022-08-02 21:40:07 * @LastEditTime: 2022-08-02 21:45:02 */
#include <bits/stdc++.h>
#define LL long long
using namespace std;
const int maxn = 1e6 + 10;
const int mod = 1e9 + 7;
const int INF = 1e9 + 10;
const int N = 1e6;
int n,m;
queue<int> q;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
cin >> n >> m;
int num = 1;
for(int i = 1;i <= n;i ++)
q.push(i);
while(!q.empty()){
if(num == m){
cout << q.front() << " ";
q.pop();
num = 1;
}
else{
num++;
q.push(q.front());//排至队尾
q.pop();
}
}
return 0;
}
边栏推荐
- 113. 授人以渔 - 如何自行查询任意 SAP UI5 控件属性的文档和技术实现细节
- 易观分析:2022年Q2中国网络零售B2C市场交易规模达23444.7亿元
- 软件测试内卷严重,如何提升自己的竞争力呢?
- UVa 437 - The Tower of Babylon (White Book)
- ML之interpret:基于titanic泰坦尼克是否获救二分类预测数据集利用interpret实现EBC模型可解释性之全局解释/局部解释案例
- 如何基于WPF写一款数据库文档管理工具(二)
- Walk the Maze BFS
- 2019年10月SQL注入的两倍
- [b01lers2020]Life on Mars
- .NET6之MiniAPI(十四):跨域CORS(上)
猜你喜欢
【开源框架】国内首个通用云计算框架,任意程序都可做成云计算。
关于IDO预售系统开发技术讲解丨浅谈IDO预售合约系统开发原理分析
Diazo Biotin-PEG3-DBCO | Diazo Compound Modified Biotin-Tripolyethylene Glycol-Dibenzocyclooctyne
LabVIEW code generation error 61056
ML之yellowbrick:基于titanic泰坦尼克是否获救二分类预测数据集利用yellowbrick对LoR逻辑回归模型实现可解释性(阈值图)案例
软件测试内卷严重,如何提升自己的竞争力呢?
Causes of Mysql Disk Holes and Several Ways to Rebuild Tables
What is the difference between the generator version and the viewer version?
First domestic open source framework 】 【 general cloud computing framework, any program can be made into cloud computing.
HCIP BGP lab report
随机推荐
2022的七夕,奉上7个精美的表白代码,同时教大家快速改源码自用
【开源框架】国内首个通用云计算框架,任意程序都可做成云计算。
软件测试内卷严重,如何提升自己的竞争力呢?
Conditional Statements for Shell Programming
亿流量大考(2):开发一套高容错分布式系统
Shell编程的条件语句
二叉搜索树解决落叶问题
First domestic open source framework 】 【 general cloud computing framework, any program can be made into cloud computing.
Recognized by International Authorities | Yunzhuang Technology was selected in "RPA Global Market Pattern Report, Q3 2022"
ML's yellowbrick: A case of interpretability (threshold map) for LoR logistic regression model using yellowbrick based on whether Titanic was rescued or not based on the two-class prediction dataset
Codeup brushing notes - simple simulation
2022-08-02 mysql/stonedb慢SQL-Q18-内存使用暴涨分析
The salary of soft testers at each stage, come to Kangkang, how much can you get?
目标检测的国内外研究现状
Embedded Systems: Clocks
Golang第二章:程序结构
RPA power business automation super order!
物联网新零售模式,引领购物新潮流
BMN: Boundary-Matching Network for Temporal Action Proposal Generation阅读笔记
Research status of target detection at home and abroad