当前位置:网站首页>Zzuli:1060 numbers in reverse order
Zzuli:1060 numbers in reverse order
2022-07-02 05:29:00 【Don't explode】
Title Description
Enter a positive integer , Output it in reverse order , There is a space after each number .
Input
Enter a positive integer n, You can assume n stay int Within the scope of
Output
take n Output in reverse order , There is a space after each number , Output takes up one line . for example , Input 12354, Output 4 5 3 2 1
The sample input Copy
12354
Sample output Copy
4 5 3 2 1
Tips
Integers n Yes 10 Take a module to get a number on a bit , And using the characteristic that integer quotient is integer , Integers n Divide 10 My business is just right “ Throw away ” A digit number
#include <stdio.h>
int main()
{
int i;
int n;
scanf("%d",&n);
int num;
for(i=0;;i++)
{
num=n%10;
n/=10;
printf("%d ",num);
if(n<1)
break;
}
return 0;
}
边栏推荐
- el form 表单validate成功后没有执行逻辑
- paddle: ValueError:quality setting only supported for ‘jpeg‘ compression
- 简单封装 js并应用
- Fabric.js 更换图片的3种方法(包括更换分组内的图片,以及存在缓存的情况)
- Global and Chinese markets for marine selective catalytic reduction systems 2022-2028: Research Report on technology, participants, trends, market size and share
- 线程池批量处理数据
- JVM class loading mechanism
- 指针使用详解
- 7.1 simulation summary
- Centos8 installation mysql8.0.22 tutorial
猜你喜欢
Fabric.js 居中元素
Using Kube bench and Kube hunter to evaluate the risk of kubernetes cluster
Disable access to external entities in XML parsing
Latest: the list of universities and disciplines for the second round of "double first-class" construction was announced
在线音乐播放器app
Storage of data
Gee series: Unit 1 Introduction to Google Earth engine
记录sentry的踩坑之路
【pyinstaller】_ get_ sysconfigdata_ name() missing 1 required positional argument: ‘check_ exists‘
摆正元素(带过渡动画)
随机推荐
Gee series: unit 6 building various remote sensing indexes in Google Earth engine
Disable access to external entities in XML parsing
Importation de studio visuel
Sliding window on the learning road
Fabric. JS free draw rectangle
ERP management system development and design existing source code
With an amount of $50billion, amd completed the acquisition of Xilinx
Gee series: Unit 4 data import and export in Google Earth engine
7.1 Résumé du concours de simulation
Fabric. JS right click menu
Draw a wave chart_ Digital IC
Gee series: Unit 2 explore datasets
Global and Chinese market of cell culture freezers 2022-2028: Research Report on technology, participants, trends, market size and share
创新永不止步——nVisual网络可视化平台针对Excel导入的创新历程
Win10 copy files, save files... All need administrator permission, solution
运维工作的“本手、妙手、俗手”
Visual Studio导入
Generate QR code
H5 jump applet
Fabric.js 更换图片的3种方法(包括更换分组内的图片,以及存在缓存的情况)