当前位置:网站首页>Insertion or Heap Sort
Insertion or Heap Sort
2022-08-03 12:59:00 【小L~~~】
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9
题目大意:
给你长度为n的两个序列,判断第二个序列是第一个序列经过插入排序还是堆排序之后的结果,然后输出是哪种排序,在输出第二个序列下一趟的排序序列。
#include<bits/stdc++.h>
using namespace std;
const int maxn = 150;
int insert[maxn], heap[maxn], a[maxn], b[maxn], n;
bool judge(int a[], int b[]) {
for(int i = 1; i <= n; i++) {
if(a[i] != b[i]) return false;
}
return true;
}
void print(int a[]) {
printf("%d", a[1]);
for(int i = 2; i <= n; i++) printf(" %d", a[i]);
}
bool insertsort(int a[]) {
for(int i = 2; i <= n; i++) {
if(a[i-1] > a[i]) {
int temp = a[i], j;
for(j = i-1; temp < a[j]; j--) a[j+1] = a[j];
a[j+1] = temp;
}
if(judge(a, b)) {
puts("Insertion Sort");
i++;
if(a[i-1] > a[i]) {
int temp = a[i], j;
for(j = i-1; temp < a[j]; j--) a[j+1] = a[j];
a[j+1] = temp;
}
print(a);
return true;
}
}
return false;
}
void HeapAdjust(int a[], int k, int len) {
a[0] = a[k];
for(int i = k * 2; i <= len; i *= 2) {
if(i < len && a[i] < a[i + 1]) i++;
if(a[0] > a[i]) break;
else {
a[k] = a[i];
k = i;
}
}
a[k] = a[0];
}
void BuildMaxHeap(int a[]) {
for(int i = n / 2; i > 0; i--)
HeapAdjust(a, i, n);
}
void heapsort(int a[]) {
BuildMaxHeap(a);
for(int i = n; i > 1; i--) {
swap(a[1], a[i]);
HeapAdjust(a, 1, i - 1);
if(judge(a, b)) {
puts("Heap Sort");
swap(a[1], a[--i]);
HeapAdjust(a, 1, i-1);
print(a);
}
}
}
int main() {
scanf("%d", &n);
for(int i = 1; i <= n; i++) {
scanf("%d", &a[i]);
insert[i] = heap[i] = a[i];
}
for(int i = 1; i <= n; i++) scanf("%d", &b[i]);
if(insertsort(insert)) return 0;
heapsort(heap);
return 0;
}
边栏推荐
- Secure Custom Web Application Login
- Blog records life
- HCIP-第十二天-MPLS+VNP
- Golang GMP principle
- 利用pgsql插件PostGIS 实现地理坐标系数据转换
- Image fusion GAN-FM study notes
- 使用Typora+EasyBlogImageForTypora写博客,无图床快速上传图片
- 易观分析:2022年Q2中国网络零售B2C市场交易规模达23444.7亿元
- [数据仓库]分层概念,ODS,DM,DWD,DWS,DIM的概念「建议收藏」
- An animation basic element movie clip effect
猜你喜欢
Hanyuan Hi-Tech G8032 standard ERPS ring network switch Gigabit 4 optical 10 electrical industrial Ethernet switch ring network + WEB management + SNMP VLAN planning
Oracle安装完毕(系统盘),从系统盘转移到数据盘
为冲销量下探中低端市场,蔚来新品牌产品定价低至10万?
【实战技能】单片机bootloader的CANFD,I2C,SPI和串口方式更新APP视频教程(2022-08-01)
实数取整写入文件(C语言文件篇)
shell编程之条件语句
PyTorch构建神经网络预测气温(数据集对比,CPU与GPU对比)
An animation basic element movie clip effect
[微服务]多级缓存
An动画基础之元件的影片剪辑动画与传统补间
随机推荐
Redis connection pool tool class
技术分享 | 接口自动化测试如何搞定 json 响应断言?
Yahoo!Answers - data set
How to disable software from running in the background in Windows 11?How to prevent apps from running in the background in Windows 11
Golang 数组和切片
使用工作队列管理器(四)
2022 年 CISO 最关心的是什么?
Jmeter use
How to build an overseas purchasing system/purchasing website - source code analysis
安防监控必备的基础知识「建议收藏」
An animation optimization of shape tween and optimization of traditional tweening
shell编程之条件语句
Autumn recruitment work
When Nodejs installation depends on cpnm, the install shows Error: Cannot find module 'fs/promises'
Basic principle of the bulk of the animation and shape the An animation tip point
The Yangtze river commercial Banks to the interview
Golang GMP principle
JS获得浏览器类型
[Deep Learning] Overview of Efficient and Lightweight Semantic Segmentation
The new interface, jingdong comment interface