当前位置:网站首页>子结点的数量(2)
子结点的数量(2)
2022-08-03 19:46:00 【-JMY-】
题目描述
给定一棵树中的若干父结点和子结点的关系描述(结点1是树根),请问该树中,每个结点有多少个子结点。
比如:读入父子关系如下(请注意:本题读入的两个数xy,不保证x是y的父)。
2 1
2 3
2 4
因此每个结点的子结点的数量分别是:1 2 0 0。
输入
第1行,读入一个整数n,表示树中结点的数量,树中的结点编号也是1~n。(n<=100)
接下来n-1行,每行有一对父子关系x y,不保证x是y的父。
输入数据保证一定合法,能够形成一棵树,且不存在重复的父子关系的读入。
输出
输出n个数,用空格隔开,表示按照编号从小到大的顺序,输出每个结点子结点的数量。
样例输入
4 2 1 2 3 2 4
样例输出
1 2 0 0
参考代码:
#include<bits/stdc++.h>
using namespace std;
int n,x,y,t[105];
int main(){
cin>>n;
for(int i=1;i<n;i++){
cin>>x>>y;
t[x]++;
t[y]++;
}
for(int i=2;i<=n;i++)
t[i]--;
for(int i=1;i<=n;i++)
cout<<t[i]<<' ';
return 0;
}
边栏推荐
- 群辉查看硬盘存储占用的方式
- ECCV2022 | 用于视频问题回答的视频图Transformer
- The effective square of the test (one question of the day 7/29)
- matplotlib画polygon, circle
- Line the last time the JVM FullGC make didn't sleep all night, collapse
- ERROR: You don‘t have the SNMP perl module installed.
- 力扣刷题之分数加减运算(每日一题7/27)
- 嵌入式分享合集27
- Network protocol-TCP, UDP difference and TCP three-way handshake, four wave
- CentOS 7 安装mysql
猜你喜欢
LeetCode 952. 按公因数计算最大组件大小
List类的超详细解析!(超2w+字)
Detailed AST abstract syntax tree
Teach you to locate online MySQL slow query problem hand by hand, package teaching package meeting
Benchmarking Lane-changing Decision-making for Deep Reinforcement Learning
深入理解JVM-内存结构
怎么将自己新文章自动推送给自己的粉丝(巨简单,学不会来打我)
微导纳米IPO过会:年营收4.28亿 君联与高瓴是股东
The ecological environmental protection management system based on mobile GIS
从文本匹配到语义相关——新闻相似度计算的一般思路
随机推荐
Redis 内存满了怎么办?这样置才正确!
ctfshow php特性
Detailed AST abstract syntax tree
epoll + 线程池 + 前后置服务器分离
Postgresql source code (65) analysis of the working principle of the new snapshot system Globalvis
Standard C language learning summary 11
622 设计循环队列——Leetcode天天刷【循环队列,数组模拟,双指针】(2022.8.2)
List类的超详细解析!(超2w+字)
详解AST抽象语法树
ScrollView嵌套RV,滑动有阻力不顺滑怎么办?
友宏医疗与Actxa签署Pre-M Diabetes TM 战略合作协议
JWT详解
【飞控开发高级教程3】疯壳·开源编队无人机-定高、定点、悬停
149. The largest number on a straight line, and check the set
危化企业双重预防机制数字化建设进入全面实施阶段
标准C语言学习总结11
Execute the mysql script file in the docker mysql container and solve the garbled characters
FreeRTOS Intermediate
钱江摩托某型号产品ECU货不对版 消费者知情权应如何保障?
ECCV2022 | 用于视频问题回答的视频图Transformer