当前位置:网站首页>Zzuli:1059 highest score
Zzuli:1059 highest score
2022-07-03 14:35:00 【Snake_____】
Title Description
Enter the grades of a group of students ( Integers ), Output highest score .
Input
The input contains multiple non negative integers and a negative integer . This negative number is not a valid result , Only indicates the end of input .
Output
Output an integer , The highest score . Take a line alone .
The sample input Copy
7 6 5 9 2 -1
Sample output Copy
9
#include <stdio.h>
int main()
{
int max=0,fen;
while(1)
{
scanf("%d",&fen);
if(fen<0)
break;
if(fen>max)
max=fen;
}
printf("%d",max);
return 0;
}
边栏推荐
- Thinking about the arrangement problem in the backtracking problem (leetcode questions 46 and 47)
- 关于敏捷的一些概念
- Convert string to decimal integer
- Zhonggan micro sprint technology innovation board: annual revenue of 240million, net loss of 17.82 million, proposed to raise 600million
- Happy capital new dual currency fund nearly 4billion yuan completed its first account closing
- 如何查询淘宝天猫的宝贝类目
- 7-16 find the set of integers that meet the given conditions
- Sendmail can't send mail and it's too slow to send. Solve it
- 分布式事务(Seata) 四大模式详解
- 动态获取权限
猜你喜欢
NPM install is stuck with various strange errors of node NPY
洛谷P4047 [JSOI2010]部落划分 题解
7-15 calculation of PI
Puzzle (016.4) domino effect
Tonybot humanoid robot infrared remote control play 0630
Understand the application scenario and implementation mechanism of differential segment
编程语言:类型系统的本质
表单文本框的使用(一) 选择文本
修改数据库中的记录为什么报这个错
X86 assembly language - Notes from real mode to protected mode
随机推荐
7-10 stack of hats (25 points) (C language solution)
ConstraintLayout 的使用
Mysql多表查询 #子查询
JVM garbage collector
Tailing rushes to the scientific and Technological Innovation Board: it plans to raise 1.3 billion, and Xiaomi Changjiang is the shareholder
Luogu p3065 [usaco12dec]first! G problem solution
修改数据库中的记录为什么报这个错
Table of mathematical constants by q779
7-24 reduction of the simplest fraction (rolling Division)
表单文本框的使用(一) 选择文本
分布式事务(Seata) 四大模式详解
Tonybot humanoid robot infrared remote control play 0630
Luogu p5536 [xr-3] core city solution
Convert string to decimal integer
Analysis of gene family characteristics - chromosome location analysis
retrofit
Happy capital new dual currency fund nearly 4billion yuan completed its first account closing
String substitution
SSH access control, blocking the IP when logging in repeatedly to prevent brute force cracking
etcd集群权限管理和账号密码使用