当前位置:网站首页>POJ 2208 已知边四面体六个长度,计算体积
POJ 2208 已知边四面体六个长度,计算体积
2022-07-06 10:20:00 【全栈程序员站长】
大家好,又见面了,我是全栈君。
Pyramids
Time Limit: 1000MS | Memory Limit: 65536K | |||
---|---|---|---|---|
Total Submissions: 2718 | Accepted: 886 | Special Judge |
Description
Recently in Farland, a country in Asia, a famous scientist Mr. Log Archeo has discovered ancient pyramids. But unlike those in Egypt and Central America, they have triangular (not rectangular) foundation. That is, they are tetrahedrons in mathematical sense. In order to find out some important facts about the early society of the country (it is widely believed that the pyramid sizes are in tight connection with Farland ancient calendar), Mr. Archeo needs to know the volume of the pyramids. Unluckily, he has reliable data about their edge lengths only. Please, help him!
Input
The file contains six positive integer numbers not exceeding 1000 separated by spaces, each number is one of the edge lengths of the pyramid ABCD. The order of the edges is the following: AB, AC, AD, BC, BD, CD.
Output
A real number — the volume printed accurate to four digits after decimal point.
Sample Input
1000 1000 1000 3 4 5
Sample Output
依据边来求出四面体的高,然后公式计算。
代码:
/* ***********************************************
Author :_rabbit
Created Time :2014/5/9 21:32:01
File Name :5.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
double volume(double a,double b,double c,double d,double e,double f){
double a2=a*a,b2=b*b,c2=c*c,d2=d*d,e2=e*e,f2=f*f;
double tr1=acos((c2+b2-f2)/(2*b*c));
double tr2=acos((a2+c2-e2)/(2*a*c));
double tr3=acos((a2+b2-d2)/(2*a*b));
double tr4=(tr1+tr2+tr3)/2;
double temp=sqrt(sin(tr4)*sin(tr4-tr1)*sin(tr4-tr2)*sin(tr4-tr3));
return a*b*c*temp/3;
}
int main()
{
//freopen("data.in","r",stdin);
//freopen("data.out","w",stdout);
double a,b,c,d,e,f;
while(cin>>a>>b>>c>>d>>e>>f)printf("%.4f\n",volume(a,b,c,d,e,f));
return 0;
}
版权声明:本文博客原创文章。博客,未经同意,不得转载。
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117405.html原文链接:https://javaforall.cn
边栏推荐
- 2019 Alibaba cluster dataset Usage Summary
- 2019阿里集群数据集使用总结
- 高精度运算
- FMT open source self driving instrument | FMT middleware: a high real-time distributed log module Mlog
- Rb157-asemi rectifier bridge RB157
- F200——搭载基于模型设计的国产开源飞控系统无人机
- 【剑指 Offer】 60. n个骰子的点数
- Insert dial file of Jerry's watch [chapter]
- Jerry's watch reads the file through the file name [chapter]
- QT中Model-View-Delegate委托代理机制用法介绍
猜你喜欢
Kivy tutorial: support Chinese in Kivy to build cross platform applications (tutorial includes source code)
Pytest learning ----- pytest confitest of interface automation test Py file details
面向程序员的精品开源字体
Distill knowledge from the interaction model! China University of science and Technology & meituan proposed virt, which combines the efficiency of the two tower model and the performance of the intera
Recommend easy-to-use backstage management scaffolding, everyone open source
關於這次通信故障,我想多說幾句…
【Swoole系列2.1】先把Swoole跑起来
30 分钟看懂 PCA 主成分分析
Virtual machine VirtualBox and vagrant installation
I want to say more about this communication failure
随机推荐
QT中Model-View-Delegate委托代理机制用法介绍
1700C - Helping the Nature
C语言自动预订飞机票问题
队列的实现
Distiller les connaissances du modèle interactif! L'Université de technologie de Chine & meituan propose Virt, qui a à la fois l'efficacité du modèle à deux tours et la performance du modèle interacti
HMS Core 机器学习服务打造同传翻译新“声”态,AI让国际交流更顺畅
std::true_ Type and std:: false_ type
Jielizhi obtains the customized background information corresponding to the specified dial [chapter]
微信为什么使用 SQLite 保存聊天记录?
2019阿里集群数据集使用总结
[swoole series 2.1] run the swoole first
Running the service with systemctl in the container reports an error: failed to get D-Bus connection: operation not permitted (solution)
Redis的五种数据结构
递归的方式
HMS core machine learning service creates a new "sound" state of simultaneous interpreting translation, and AI makes international exchanges smoother
ASEMI整流桥DB207的导通时间与参数选择
D binding function
UDP protocol: simple because of good nature, it is inevitable to encounter "city can play"
std::true_type和std::false_type
阿里云国际版ECS云服务器无法登录宝塔面板控制台