当前位置:网站首页>统计单词(DAY 101)华中科技大学考研机试题
统计单词(DAY 101)华中科技大学考研机试题
2022-08-04 23:36:00 【张学恒】
1:题目
编写一个程序,读入用户输入的,以 . 结尾的一行文字,统计一共有多少个单词,并分别输出每个单词含有多少个字符。 (凡是以一个或多个空格隔开的部分就为一个单词)
输入格式
共一行,包含一个以 . 结尾的字符串。
注意,最后一个单词后面会直接跟一个 . 表示句子结束,但是该 . 并不计入单词中。
输出格式
共一行,按顺序输出字符串中每个单词包含的字母的个数。
数据范围
字符串长度不超过 1000。
输入样例:
hello how are you.
输出样例:
5 3 3 3
2:代码实现
一直读入 while (cin>> s) str[k++]=s;
把输入的数据读入到一个数组中,完成了 存储和 ++ 的过程
str[k]=s;
k++;
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1010;
string str[N];
string s;
int main()
{
int k=0;
while(cin>> s)str[k++]=s;
for(int i=0;i<k-1;i++)cout << str[i].size()<< ' ';
cout << str[k-1].size()-1;
return 0;
}
边栏推荐
- Since a new byte of 20K came out, I have seen what the ceiling is
- Pytorch分布式训练/多卡/多GPU训练DDP的torch.distributed.launch和torchrun
- 365天深度学习训练营-学习线路
- 【CVA估值训练营】财务建模指南——第一讲
- [Happy Qixi Festival] How does Nacos realize the service registration function?
- [Cultivation of internal skills of string functions] strcpy + strcat + strcmp (1)
- 隐私计算综述
- enumerate()函数
- Linear DP (bottom)
- 线程三连鞭之“线程的状态”
猜你喜欢
Literature reading ten - Detect Rumors on Twitter by Promoting Information Campaigns with Generative Adversarial Learn
Develop a SpaceX website based on the Appian low-code platform
年薪50W+的测试工程师都在用这个:Jmeter 脚本开发之——扩展函数
Pytest learning - fixtures
OPENCV学习DAY8
Flutter启动流程(Skia引擎)介绍与使用
NebulaGraph v3.2.0 Release Note, many optimizations such as the performance of querying the shortest path
The market value of 360 has evaporated by 390 billion in four years. Can government and enterprise security save lives?
安全软件 Avast 与赛门铁克诺顿 NortonLifeLock 合并案获英国批准,市值暴涨 43%
Bidding Announcement | Operation and Maintenance Project of Haina Baichuang Official Account
随机推荐
CS8416国产替代DP8416 数字音频接收器
@Import注解的作用以及如何使用
Ab3d.PowerToys and Ab3d.DXEngine Crack
Web安全开发 | 青训营笔记
Literature reading ten - Detect Rumors on Twitter by Promoting Information Campaigns with Generative Adversarial Learn
学会反射后,我被录取了(干货)
4-《PyTorch深度学习实践》-反向传播
【字符串函数内功修炼】strncpy + strncat + strncmp(二)
社区分享|腾讯海外游戏基于JumpServer构建游戏安全运营能力
Pytorch分布式训练/多卡/多GPU训练DDP的torch.distributed.launch和torchrun
基于Appian低代码平台开发一个SpaceX网站
NebulaGraph v3.2.0 Release Note, many optimizations such as the performance of querying the shortest path
uniapp动态实现滑动导航效果demo(整理)
一点点读懂cpufreq(二)
Security software Avast and Symantec NortonLifeLock merge with UK approval, market value soars 43%
如何根据地址获取函数名
招标公告 | 海纳百创公众号运维项目
Pytest learning - fixtures
Shell expect real cases
【手撕AHB-APB Bridge】~ AMBA总线 之 AHB