当前位置:网站首页>trie树模板
trie树模板
2022-08-05 10:28:00 【一条小小yu】
题目:Trie字符串统计
维护一个字符串集合,支持两种操作:
I x
向集合中插入一个字符串 xx;Q x
询问一个字符串在集合中出现了多少次。
共有 N个操作,输入的字符串总长度不超过 10^5,字符串仅包含小写英文字母。
输入格式
第一行包含整数 N,表示操作数。
接下来 N 行,每行包含一个操作指令,指令为 I x
或 Q x
中的一种。
输出格式
对于每个询问指令 Q x
,都要输出一个整数作为结果,表示 x 在集合中出现的次数。
每个结果占一行。
数据范围
1≤N≤2∗10^4 1≤N≤2∗10^4
输入样例:
5
I abc
Q abc
Q ab
I ab
Q ab
输出样例:
1
0
1
#include<iostream>
using namespace std;
const int N=1e5+10;
int son[N][26],cnt[N],idx;
char str[N];
void insert(char str[])
{
int p=0;
for(int i=0;str[i];i++)
{
int u=str[i]-'a';
if(!son[p][u])son[p][u]=++idx;
p=son[p][u];
}
cnt[p]++;
}
int query(char str[])
{
int p=0;
for(int i=0;str[i];i++)
{
int u=str[i]-'a';
if(!son[p][u])return 0;
p=son[p][u];
}
return cnt[p];
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
char op[2];
scanf("%s%s",op,str);
if(op[0]=='I')insert(str);
else printf("%d\n",query(str));
}
return 0;
}
边栏推荐
- Development common manual link sharing
- LeetCode 216. Combined Sum III (2022.08.04)
- 基于MindSpore高效完成图像分割,实现Dice!
- MySQL事务
- 阿里顶级架构师多年总结的JVM宝典,哪里不会查哪里!
- Chapter 5: Multithreaded Communication—wait and notify
- Create a Dapp, why choose Polkadot?
- SMB + SMB2: Accessing shares return an error after prolonged idle period
- 19.3 restart the Oracle environment
- PCB布局必知必会:教你正确地布设运算放大器的电路板
猜你喜欢
RT-Thread记录(一、RT-Thread 版本、RT-Thread Studio开发环境 及 配合CubeMX开发快速上手)
气象数据数据处理实例——matlab字符串切割匹配与R语言日期匹配(数据拼接)
RT - Thread record (a, RT, RT Thread version - Thread Studio development environment and cooperate CubeMX quick-and-dirty)
three.js debugging tool dat.gui use
Opencv算术操作
登录功能和退出功能(瑞吉外卖)
SD NAND Flash简介!
The JVM collection that Alibaba's top architects have summarized for many years, where can't I check it!
用KUSTO查询语句(KQL)在Azure Data Explorer Database上查询LOG实战
The founder of the DFINITY Foundation talks about the ups and downs of the bear market, and where should DeFi projects go?
随机推荐
一文道清什么是SPL
阿里顶级架构师多年总结的JVM宝典,哪里不会查哪里!
Leetcode刷题——623. 在二叉树中增加一行
这份阿里强推的并发编程知识点笔记,将是你拿大厂offer的突破口
上位机开发C#语言:模拟STC串口助手接收单片机发送数据
PCB布局必知必会:教你正确地布设运算放大器的电路板
电竞、便捷、高效、安全,盘点OriginOS功能的关键词
60行从零开始自己动手写FutureTask是什么体验?
阿里全新推出:微服务突击手册,把所有操作都写出来了PDF
气象数据数据处理实例——matlab字符串切割匹配与R语言日期匹配(数据拼接)
SkiaSharp 之 WPF 自绘 投篮小游戏(案例版)
华为轻量级神经网络架构GhostNet再升级,GPU上大显身手的G-GhostNet(IJCV22)
【MindSpore易点通机器人-01】你也许见过很多知识问答机器人,但这个有点不一样
【 temperature warning program DE development 】 event driven model instance
还在找网盘资源吗?快点收藏如下几个值得收藏的网盘资源搜索神器吧!
MySQL之数据视图
JS introduction to reverse the recycling business network of learning, simple encryption mobile phone number
项目成本控制如何帮助项目成功?
Confessing in the era of digital transformation: Mai Cong Software allows enterprises to use data in the easiest way
The JVM collection that Alibaba's top architects have summarized for many years, where can't I check it!