当前位置:网站首页>信息学奥赛一本通(1257:Knight Moves)
信息学奥赛一本通(1257:Knight Moves)
2022-08-02 20:02:00 【橙子教师】
1257:Knight Moves
时间限制: 1000 ms 内存限制: 65536 KB
提交数: 6149 通过数: 3100
【题目描述】
输入nn代表有个n×n的棋盘,输入开始位置的坐标和结束位置的坐标,问一个骑士朝棋盘的八个方向走马字步,从开始坐标到结束坐标可以经过多少步。
【输入】
首先输入一个nn,表示测试样例的个数。
每个测试样例有三行。
第一行是棋盘的大小L(4≤L≤300);
第二行和第三行分别表示马的起始位置和目标位置(0..L−1)。
【输出】
马移动的最小步数,起始位置和目标位置相同时输出00。
【输入样例】
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
【输出样例】
5
28
0
【分析】
马走日,8个方向,方向数组(1,2),(1,-2),(-1,2),(-1,-2),(2,1),(2,-1),(-2,1),(-2,-1)。
【参考代码】
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int N=310;
struct node
{
int x,y;
int t;
};
int sx,sy; //起点坐标
int ex,ey; //终点坐标
int l; //棋盘大小
int dx[]={1,1,-1,-1,2,2,-2,-2}; //方向数组
int dy[]={2,-2,2,-2,1,-1,1,-1};
bool vis[N][N]; //访问数组
void bfs()
{
queue <node> q; //申请队列
node st;
st.x=sx;
st.y=sy;
st.t=0;
q.push(st); //起点入队
while(!q.empty())
{
node nt=q.front();
if(nt.x==ex && nt.y==ey)
{
cout<<nt.t<<endl;
break;
}
for(int i=0;i<8;i++)
{
int nx=nt.x+dx[i];
int ny=nt.y+dy[i];
if(vis[nx][ny]==false && nx>=0 && nx<l && ny>=0 && ny<l)
{
vis[nx][ny]=true;
node tmp;
tmp.x=nx;
tmp.y=ny;
tmp.t=nt.t+1;
q.push(tmp);
}
}
q.pop();
}
return;
}
int main()
{
int t;
cin>>t;
while(t--)
{
memset(vis,false,sizeof(vis));
cin>>l;
cin>>sx>>sy>>ex>>ey;
vis[sx][sy]=true;
bfs();
}
}
边栏推荐
- SQL Server实现group_concat功能
- Redis cluster configuration
- PG's SQL execution plan
- 当TIME_WAIT状态的TCP正常挥手,收到SYN后…
- ECCV 2022 | 通往数据高效的Transformer目标检测器
- 网络协议介绍
- 日志框架学习
- 特拉维夫大学 | Efficient Long-Text Understanding with Short-Text Models(使用短文本模型进行高效的长文本理解)
- [AnXun cup 2019] easy_web
- J9 digital theory: the Internet across chain bridge has what effect?
猜你喜欢
如何ES源码中添加一个自己的API 流程梳理
PG's SQL execution plan
Caldera(一)配置完成的虚拟机镜像及admin身份简单使用
基于 outline 实现头像剪裁以及预览
日志框架学习
TPAMI2022 | TransCL:基于Transformer的压缩学习,更灵活更强大
shell:条件语句
腾讯云孟凡杰:我所经历的云原生降本增效最佳实践案例
译出我精彩 | 7月墨力翻译计划获奖名单公布
A Review of Nature Microbiology: Focusing on the Algae--Ecological Interface of Phytoplankton-Bacteria Interactions
随机推荐
el-tree渲染大量数据的解决方案(不通过懒加载)
APP自动化uiautomator2获取toast
模板的进阶
MySQL安装配置教程(超级详细、保姆级)
J9数字货币论:识别Web3新的稀缺性:开源开发者
LeetCode:622. 设计循环队列【模拟循环队列】
You want the metagenomics - microbiome knowledge in all the (2022.8)
牛客题目——滑动窗口的最大值、矩阵最长递增路径、顺时针旋转矩阵、接雨水问题
OpenCV开发中的内存管理问题
EasyExcel实现动态列解析和存表
MySQL安装(详细,适合小白)
一款好用的FAQ搭建工具
SQL 嵌套 N 层太长太难写怎么办?
Parse the commonly used methods in the List interface that are overridden by subclasses
SCANIA SCANIA OTL tag is introduced
网络协议介绍
B站HR对面试者声称其核心用户都是生活中的Loser
PG 之 SQL执行计划
es 官方诊断工具
Kali命令ifconfig报错command not found