当前位置:网站首页>-一尺之棰-
-一尺之棰-
2022-08-03 05:10:00 【-JMY-】
题目描述
《庄子》中说到,“一尺之棰,日取其半,万世不竭”。第一天有一根长度为 a(1<=a<=10^9)的木棍,从第二天开始,每天都要将这根木棍锯掉一半(每次除 2,向下取整)。第几天的时候木棍的长度会变为 1?
输入
木棍的长度a
输出
木棍的长度变为1所需的天数
样例输入
100
样例输出
7
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
int a,s;
cin>>a;
while(a!=1){
s++;
a/=2;
}
cout<<s+1;
}
边栏推荐
猜你喜欢
Djiango第四次培训笔记
[Harmony OS] [ArkUI] ets development graphics and animation drawing
Js学习笔记(四)
数据分析 第一篇
2017-06-11 Padavan 完美适配newifi mini【adbyby+SS+KP ...】youku L1 /小米mini
【HMS core】【Ads Kit】Huawei Advertising——Overseas applications are tested in China. Official advertisements cannot be displayed
Talking about GIS Data (6) - Projected Coordinate System
在树莓派上搭建属于自己的网页(1)
GIS数据漫谈(六)— 投影坐标系统
typescript39-class类的可见修饰符
随机推荐
【 Harmony OS 】 【 ano UI 】 lightweight data storage
Build your own web page on raspberry pie (1)
曲线特征----曲线弯曲程度的探究
presto安装部署教程
Djiango第二次培训
-整数求和-
用户密码加密工具
typescript40-class类的保护修饰符
Detailed explanation of MOSN reverse channel
web安全-SSTI模板注入漏洞
Kaggle 入门(Kaggle网站使用及项目复现)
HarmonyOS应用开发培训第二次作业
ss-4.1-1个eurekaServer+1个providerPayment+1个consumerOrder
接口和抽象
《录取通知》 观后感
【Flask】Flask-SQLAlchemy的增删改查(CRUD)操作
Common fluorescent dyes to modify a variety of groups and its excitation and emission wavelength data in the data
安装IIS服务(Internet信息服务(Internet Information Services,简写IIS,互联网信息服务)
Presto installation and deployment tutorial
js实现一个 bind 函数