当前位置:网站首页>HDU - 1078 fatmouse and cheese (memory search DP)
HDU - 1078 fatmouse and cheese (memory search DP)
2022-07-04 21:50:00 【WA_ automata】
HDU - 1078 FatMouse and Cheese
Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.
FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of
a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37
#include<iostream>
#include<cstring>
using namespace std;
const int N = 110;
const int dx[4]={
-1,0,1,0},dy[4]={
0,1,0,-1};
int g[N][N],ans[N][N];
int n,k;
int dfs(int x,int y)
{
if(ans[x][y]) return ans[x][y];
else
{
int sum=0;
for(int i=0;i<4;i++)
for(int j=1;j<=k;j++)
{
int xx=x+j*dx[i],yy=y+j*dy[i];
if(xx>=1&&xx<=n&&yy>=1&&yy<=n&&g[xx][yy]>g[x][y])
sum=max(sum,dfs(xx,yy));
}
ans[x][y]=sum+g[x][y];
return ans[x][y];
}
}
int main()
{
while(cin>>n>>k)
{
if(n==-1&&k==-1) break;
memset(ans,0,sizeof ans);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
cin>>g[i][j];
cout<<dfs(1,1)<<endl;
}
return 0;
}
边栏推荐
- 类方法和类变量的使用
- Caduceus从未停止创新,去中心化边缘渲染技术让元宇宙不再遥远
- Jerry's ad series MIDI function description [chapter]
- HDU - 2859 Phalanx(DP)
- Jerry's ad series MIDI function description [chapter]
- 2021 CCPC Harbin B. magical subsequence (thinking question)
- Keep on fighting! The city chain technology digital summit was grandly held in Chongqing
- 开源之夏专访|Apache IoTDB社区 新晋Committer谢其骏
- GTEST from ignorance to proficiency (4) how to write unit tests with GTEST
- Daily question-leetcode556-next larger element iii-string-double pointer-next_ permutation
猜你喜欢
[leetcode] 17. Letter combination of telephone number
Lambdaquerywrapper usage
Stealing others' vulnerability reports and selling them into sidelines, and the vulnerability reward platform gives rise to "insiders"
TCP三次握手,四次挥手,你真的了解吗?
torch. Tensor and torch The difference between tensor
Arcgis 10.2.2 | arcgis license server无法启动的解决办法
每日一题-LeetCode556-下一个更大元素III-字符串-双指针-next_permutation
历史最全混合专家(MOE)模型相关精选论文、系统、应用整理分享
输入的查询SQL语句,是如何执行的?
How was MP3 born?
随机推荐
redis03——Redis的网络配置与心跳机制
Difference between ApplicationContext and beanfactory (MS)
MYSQL 用!=查询不出等于null的数据,解决办法
Flutter WebView示例
旋变串判断
How was MP3 born?
Can be displayed in CAD but not displayed in print
Jerry added the process of turning off the touch module before turning it off [chapter]
挖财学院股票开户安全吗?开户只能在挖财开户嘛?
Billions of citizens' information has been leaked! Is there any "rescue" for data security on the public cloud?
做BI开发,为什么一定要熟悉行业和企业业务?
Flink1.13 SQL basic syntax (I) DDL, DML
At the right time, the Guangzhou station of the city chain science and Technology Strategy Summit was successfully held
Stealing others' vulnerability reports and selling them into sidelines, and the vulnerability reward platform gives rise to "insiders"
Drop down selection of Ehlib database records
股票开户流程是什么?使用同花顺手机炒股软件安全吗?
gtest从一无所知到熟练运用(1)gtest安装
OMS系统实战的三两事
Delphi SOAP WebService 服务器端多个 SoapDataModule 实现相同的接口方法,接口继承
GTEST from ignorance to proficiency (3) what are test suite and test case