当前位置:网站首页>-元素之和-
-元素之和-
2022-08-03 05:10:00 【-JMY-】
题目描述
输入4*4方阵。
输入
输入4*4方阵,分别求两条对角线上元素之和。
输出
输出两条对角线上元素之和(如样例所示)。
样例输入
0 0 2 7 5 3 2 1 9 9 7 0 9 1 9 5
样例输出
15 27
参考代码
#include<bits/stdc++.h>
using namespace std;
int main(){
int a[5][5],b=0,c=0;
for(int i=1;i<=4;i++)
{
for(int j=1;j<=4;j++)
{
cin>>a[i][j];
}
}
for(int i=1;i<=4;i++)
{
b+=a[i][i];
c+=a[i][5-i];
}
cout<<b<<" "<<c;
return 0;
}
边栏推荐
猜你喜欢
随机推荐
轨迹(形状)相似性判断与度量方法
JDBC与连接池
[Harmony OS] [ARK UI] ETS context basic operations
【Flask】Flask-SQLAlchemy的增删改查(CRUD)操作
Lambda表达式案例
NotImplementedError: file structure not yet supported
-飞机大战-
在树莓派上搭建属于自己的网页(2)
ss-4.2 多个eureka集群案例
深度学习入门之GRU
OptionError: ‘Pattern matched multiple keys‘
User password encryption tool
Super handy drawing tool is recommended
tag单调栈-单调栈预备知识-lt.739. 每日温度
Detailed explanation of MOSN reverse channel
生活原则。
Djiango第四次培训笔记
ss-1.curl (cloud-provider-payment8001)
UV decomposition of biotin - PEG2 - azide | CAS: 1192802-98-4 biotin connectors
设计模式——组合模式、享元模式(Integer缓存)(结构型模式)