当前位置:网站首页>放苹果(暑假每日一题 13)
放苹果(暑假每日一题 13)
2022-08-02 11:08:00 【sweetheart7-7】
把 M M M 个同样的苹果放在 N N N 个同样的盘子里,允许有的盘子空着不放,问共有多少种不同的分法?
盘子相对顺序不同,例如 5 , 1 , 1 5,1,1 5,1,1 和 1 , 5 , 1 1,5,1 1,5,1 算作同一种分法。
输入格式
输入包含多组测试数据。
每组数据占一行,包含两个整数 M M M 和 N N N。
输出格式
每组数据,输出一行一个结果表示分法数量。
数据范围
1 ≤ M , N ≤ 10 1≤M,N≤10 1≤M,N≤10
输入样例:
7 3
输出样例:
8
#include<iostream>
using namespace std;
int m, n;
int dfs(int u, int sum, int last){
if(u == n)
return sum == 0;
int res = 0;
for(int i = last; i <= sum; i++)
res += dfs(u + 1, sum - i, i);
return res;
}
int main(){
while(cin >> m >> n)
cout << dfs(0, m, 0) << endl;
return 0;
}
边栏推荐
- 【面向校招】Golang面试题合集
- 阿里云数据存储生态计划发布,助力伙伴数据创新
- yolo格式(txt)数据集转VOC(xml)
- 当POC遇见RPA:RPA项目顺利实施的关键
- Shell编程之条件语句
- org.apache.ibatis.binding.BindingException Invalidbound statement (not found)的解决方案和造成原因分析(超详细)
- 循环结构--do-while循环
- 循环结构--while循环
- MSYS2 QtCreator Clangd code analysis can not find mm_malloc.h problem remedy
- Kotlin的协程与生命周期
猜你喜欢
games202:三,实时环境光照IBL + PRT
Jay Chou's new song is released, crawl the "Mojito" MV barrage, and see what the fans have to say!
QT笔记——QT类反射机制简单学习
多大数量级会出现哈希碰撞
详细总结SoC、DSP、MCU、GPU和FPGA等基础概念
ssm web page access database data error
华为eNSP(基础实验通信)
小几届的学弟问我,软件测试岗是选11k的华为还是20k的小公司,我直呼受不了,太凡尔赛了~
多线程(基础) - 4万字总结
开箱即用-使用异步加载布局来优化页面启动速度的几种方案
随机推荐
配置mysql失败了,这是怎么回事呢?
OSI 七层模型和TCP/IP模型及对应协议(详解)
The exchange - string dp
SVN如何删除文件名包含空格的文件
Getting Started with Three.JS Programmatic Modeling
Deep Learning 100 Examples - Convolutional Neural Network (CNN) for mnist handwritten digit recognition
Excel动态图制作
当POC遇见RPA:RPA项目顺利实施的关键
3 d laser slam: LeGO - LOAM - ground point extracting method and the analysis of the code
LayaBox---TypeScript---Module Analysis
WPF 截图控件之文字(七)「仿微信」
QT笔记——在一个窗口上显示另外一个透明窗口
4年手工测试被应届生取代了,用血与泪的教训给xdm一个忠告,该学自动化了...
Alibaba CTO Cheng Li: Alibaba Open Source History, Concept and Practice
LayaBox---TypeScript---Namespaces and modules
从零开始Blazor Server(5)--权限验证
博云入选Gartner中国DevOps代表厂商
LayaBox---TypeScript---Three slash instructions
LayaBox---TypeScript---装饰器
MSYS2 QtCreator Clangd code analysis can not find mm_malloc.h problem remedy