当前位置:网站首页>【Acwing】The 62nd Weekly Game Solution
【Acwing】The 62nd Weekly Game Solution
2022-07-31 22:48:00 【Xuan Che_】
AcWing 4500. 三个元素
输入样例1:
6 3 1 4 1 5 9
输出样例1:
4 1 3
输入样例2:
5 1 1000000000 1 1000000000 1
输出样例2:
-1 -1 -1
输入样例3:
9 10 10 11 10 10 10 10 10 1
输出样例3:
9 8 3
方法一:Read in and find first max 和 min 值 ,Then loop again to find any
,The final judgment can be made
#include <iostream> #include <algorithm> using namespace std; const int N = 3010, INF = 0x3f3f3f3f; int a[N]; int main() { int max = 0, min = INF, mid = 0; int i1 = -1, i2 = -1 , i3 = -1; int n; cin >> n; for(int i = 1; i <= n; i ++ ) { cin >> a[i]; if(a[i] > max) max = a[i], i1 = i; if(a[i] < min) min = a[i], i2 = i; } for(int i = 1; i <= n; i ++ ) { if(a[i] > min && a[i] < max) mid = a[i], i3 = i; } //printf("%d %d %d\n", min, max, mid); if(max != min && max != mid && min != mid && i1 != i2 && i1 != i3 && i2 != i3 && i1 != -1 && i2 != -1 && i3 != -1) { printf("%d %d %d", i2, i3, i1); } else puts("-1 -1 -1"); return 0; }
方法2:使用mapto store and judge
#include <iostream> #include <cstring> #include <map> #include <vector> using namespace std; int main() { int n; cin >> n; map<int, int> pos; for(int i = 1; i <= n; i ++ ) { int x; cin >> x; pos[x] = i; } if(pos.size() < 3) puts("-1 -1 -1"); else { vector<int> res; for(auto [k, v] : pos) res.push_back(v); for(int i = 0; i < 3; i ++ ) cout << res[i] << ' '; } return 0; }
AcWing 4501. 收集卡牌
输入样例1:
3 11 2 3 1 2 2 2 3 2 2 3 1
输出样例1:
00100000001
输入样例2:
4 8 4 1 3 3 2 3 3 3
输出样例2:
00001000
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 100010;
int n, m;
int cnt[N];
int main()
{
cin >> n >> m;
int tot = 0;
while(m -- )
{
int x; scanf("%d", &x);
if(!cnt[x]) tot ++ ;
cnt[x] ++ ;
if(tot == n)
{
printf("1");
for(int i = 1; i <= n; i ++ )
if(-- cnt[i] == 0)
tot -- ;
}
else
{
printf("0");
}
}
return 0;
}
AcWing 4502. 集合操作
输入样例1:
6 1 3 2 1 4 2 1 8 2
输出样例1:
0.000000 0.500000 3.000000
输入样例2:
4 1 1 1 4 1 5 2
输出样例2:
2.000000
#include <iostream> #include <cstring> #include <algorithm> using namespace std; const int N = 500010; int n, m; int w[N]; int main() { scanf("%d", &m); double res = 0, sum = 0; int k = 0; while (m -- ) { int op, x; scanf("%d", &op); if (op == 1) { scanf("%d", &x); w[ ++ n] = x; while (k + 1 <= n && w[k + 1] <= (sum + w[n]) / (k + 1)) sum += w[ ++ k]; res = max(res, w[n] - (sum + w[n]) / (k + 1)); } else { printf("%lf\n", res); } } return 0; }
边栏推荐
猜你喜欢
VOT2021比赛简介
二叉树非递归遍历
Payment module implementation
flowable workflow all business concepts
VOT2021 game introduction
高效并发:Synchornized的锁优化详解
Student management system on the first day: complete login PyQt5 + MySQL5.8 exit the operation logic
[Code Hoof Set Novice Village 600 Questions] Leading to the combination of formulas and programs
AI automatic code writing plugin Copilot (co-pilot)
Judging decimal points and rounding of decimal operations in Golang
随机推荐
顺序表的实现
输入输出优化
Niuke.com brush questions (1)
基于RT1052 Aworks nanopb string 类型固定长度使用方式(二十七)
Summary of the classic drawing method of histogram
Flink_CDC construction and simple use
focus on!Haitai Fangyuan joins the "Personal Information Protection Self-discipline Convention"
In Golang go-redis cluster mode, new connections are constantly created, and the problem of decreased efficiency is solved
"SDOI2016" Journey Problem Solution
BM3 flips the nodes in the linked list in groups of k
Pytest初体验
Verilog implements a divide-by-9 with a duty cycle of 5/18
Bika LIMS open source LIMS set - use of SENAITE (detection process)
One thing to say, is outsourcing company worth it?
cas and spin locks (is lightweight locks spin locks)
HTC使用官方固件作为底包制作rom卡刷包教程
Student management system on the first day: complete login PyQt5 + MySQL5.8 exit the operation logic
Federated Learning: Multi-source Knowledge Graph Embedding in Federated Scenarios
Golang must know the Go Mod command
@JsonFormat(pattern="yyyy-MM-dd") time difference problem