当前位置:网站首页>PAT乙级-B1013 数素数(20)
PAT乙级-B1013 数素数(20)
2022-08-03 14:20:00 【nekoha_dexter】
令 Pi 表示第 i 个素数。现任给两个正整数 M≤N≤104,请输出 PM 到 PN 的所有素数。
输入格式:
输入在一行中给出 M 和 N,其间以空格分隔。
输出格式:
输出从 PM 到 PN 的所有素数,每 10 个数字占 1 行,其间以空格分隔,但行末不得有多余空格。
输入样例:
5 27
输出样例:
11 13 17 19 23 29 31 37 41 43
47 53 59 61 67 71 73 79 83 89
97 101 103
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1000000
bool PrimeTable[maxn];
//1、埃氏筛法,在过程中对素数进行编号
//2、当第M个素数,开始考虑输出
//2.1、输出时,考虑没十个或第N个都要输出回车
//2.2、输出后考虑是否已到第N个了,是则跳出
//3、maxn 建议到10^6,否则会出现段错误,无法ac
void get(const int m, const int n){
int cnt = 0;
for(int i = 2; i <= maxn; ++i)
if(PrimeTable[i]){
cnt++;
if(cnt >= m){
cout << i;
if((cnt - m + 1) % 10 == 0 || cnt == n) cout << endl;
else cout << " ";
}
if(cnt >= n) return;
for(int j = i * 2; j <= maxn; j +=i)
PrimeTable[j] = false;
}
}
int main(){
int m, n;
cin >> m >> n;
fill(PrimeTable, PrimeTable + maxn, true);
get(m, n);
}
边栏推荐
- atrace和systrace的基本使用方法
- Left index of all anagrams in leetcode/string (some permutation of s1 string is a substring of s2)
- 【问题】使用pip安装第三方库的时候遇到“timeout”的解决方法
- Controller层代码这么写,简洁又优雅!
- 利用 NFT 释放网站的潜力
- 利用华为云ECS服务器搭建安防视频监控平台【华为云至简致远】
- 位级运算之提取位级表示的最高位
- GMapping原理分析[通俗易懂]
- PCL 点云按时间进行分段
- The embassy in Iceland reminds Chinese citizens in Iceland to strengthen safety protection
猜你喜欢
随机推荐
“杀猪盘”宰向环球影城
idea找不到class,gradle依赖已经加载,并且class可看
OpenHarmony高校技术俱乐部计划发布
Huffman tree
淘特:引擎还是包袱?
Left index of all anagrams in leetcode/string (some permutation of s1 string is a substring of s2)
[A summary of the sorting and use of activation functions in deep learning]
豪威集团发布新款5000万像素图像传感器OV50E
ideaIU-2020.1下载
The Chinese Embassy in Nigeria issued an emergency safety warning for the area near Zuma Rock in Abuja
PostgreSQL 每周新闻 2022-7-27
连亏四个月,赚不回电费,预制菜经销商恐成“韭菜”?
系统学习Shell之正则表达式
PostgreSQL V14中更好的SQL函数
兆骑科创高层次人才引进平台,创新创业赛事活动路演
基于.NET 6 的开源访客管理系统
STL——vector
W11的右键如何改成和W10一样?(一行命令即可解决!)
VMware 虚拟机如何连接网络「建议收藏」
【web渗透】CSRF漏洞详细讲解