当前位置:网站首页>905. 区间选点
905. 区间选点
2022-08-05 03:07:00 【Hunter_Kevin】
905. 区间选点
给定 N 个闭区间 [ai,bi],请你在数轴上选择尽量少的点,使得每个区间内至少包含一个选出的点。
输出选择的点的最小数量。
位于区间端点上的点也算作区间内。
输入格式
第一行包含整数 N,表示区间数。
接下来 N 行,每行包含两个整数 ai,bi,表示一个区间的两个端点。
输出格式
输出一个整数,表示所需的点的最小数量。
数据范围
1≤N≤105,
−109≤ai≤bi≤109
输入样例:
3
-1 1
2 4
3 5
输出样例:
2
代码
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 100010;
typedef pair<int,int> PII;
PII a[N];
bool comp(PII x, PII y)
{
return x.second < y.second;
}
int main()
{
int n;
cin >> n;
for(int i = 0; i < n; i++)cin >> a[i].first >> a[i].second;
// 根据区间右端点大小排序
sort(a,a+n,comp);
// 每次选择区间的右端点作为选点
int r = a[0].second;
int res = 1;
for(int i = 1; i < n; i++){
if(a[i].first > r){
//如果当前区间的左端点>选点 即区间不包括选点,则更新区间边界和新的选点
res++;
r = a[i].second;
}//如果当前区间的左端点<=选点,则忽略当前区间,继续判断下一个区间
}
cout << res << endl;
return 0;
}
边栏推荐
- 你要的七夕文案,已为您整理好!
- Programmer's Tanabata Romantic Moment
- rpc-remote procedure call demo
- QT: The Magical QVarient
- The usage of try...catch and finally in js
- private封装
- private package
- 云原生(三十二) | Kubernetes篇之平台存储系统介绍
- [Fortune-telling-60]: "The Soldier, the Tricky Way"-2-Interpretation of Sun Tzu's Art of War
- ASP.NET application--Hello World
猜你喜欢
How to Add Category-Specific Widgets in WordPress
为什么pca分量没有关联
The usage of try...catch and finally in js
mysql没法Execute 大拿们求解
After the large pixel panorama is completed, what are the promotion methods?
云原生(三十二) | Kubernetes篇之平台存储系统介绍
CPDA|How Operators Learn Data Analysis (SQL) from Negative Foundations
QT language file production
A small tool to transfer files using QR code - QFileTrans 1.2.0.1
dmp(dump)转储文件
随机推荐
剑指Offer--找出数组中重复的数字(三种解法)
IJCAI2022 | DictBert: Pre-trained Language Models with Contrastive Learning for Dictionary Description Knowledge Augmentation
为什么pca分量没有关联
Never put off till tomorrow what you can put - house lease management system based on the SSM
In 2022, you still can't "low code"?Data science can also play with Low-Code!
J9 Digital Currency: What is the creator economy of web3?
private package
1527. 患某种疾病的患者
QStyle平台风格
VSCode Change Default Terminal how to modify the Default Terminal VSCode
从“能用”到“好用” 国产软件自主可控持续推进
Matlab drawing 3
mysql没法Execute 大拿们求解
思考(八十八):使用 protobuf 自定义选项,做数据多版本管理
链表的简单描述及代码的简单实现
word分栏小记
The usage of try...catch and finally in js
Countdown to 2 days|Cloud native Meetup Guangzhou Station, waiting for you!
Review 51 MCU
(十一)元类