当前位置:网站首页>语法基础(变量、输入输出、表达式与顺序语句完成情况)
语法基础(变量、输入输出、表达式与顺序语句完成情况)
2022-08-05 02:34:00 【进击攻城狮】
1.A+B
输入两个整数,求这两个整数的和是多少。
输入格式
输入两个整数A,BA,B,用空格隔开
输出格式
输出一个整数,表示这两个数的和
数据范围
0≤A,B≤1080≤A,B≤108
样例输入:
3 4
样例输出:
7
#include<iostream>
using namespace std;
int a,b,c ;
int main(){
cin>>a>>b>>c;
c=a+b;
cout<<c<<endl;
return 0;
}
608.差
读取四个整数 A,B,C,DA,B,C,D,并计算 (A×B−C×D)(A×B−C×D) 的值。
输入格式
输入共四行,第一行包含整数 AA,第二行包含整数 BB,第三行包含整数 CC,第四行包含整数 DD。
输出格式
输出格式为 DIFERENCA = X
,其中 XX 为 (A×B−C×D)(A×B−C×D) 的结果。
数据范围
−10000≤A,B,C,D≤10000−10000≤A,B,C,D≤10000
输入样例:
5
6
7
8
输出样例:
DIFERENCA = -26
#include<cstdio>
using namespace std;
int A,B,C,D;
int main(){
scanf("%d%d%d%d",&A,&B,&C,&D);
printf("DIFERENCA = %d\n",A*B-C*D);
return 0;
}
604. 圆的面积
计算圆的面积的公式定义为 A=πR2A=πR2。
请利用这个公式计算所给圆的面积。
ππ 的取值为 3.141593.14159。
输入格式
输入包含一个浮点数,为圆的半径 RR。
输出格式
输出格式为 A=X
,其中 XX 为圆的面积,用浮点数表示,保留四位小数。
数据范围
0<R<10000.000<R<10000.00
输入样例:
2.00
输出样例:
A=12.5664
#include<cstdio>
using namespace std;
int main(){
double PI=3.14159;
double R;
scanf("%lf",&R);
printf("A=%.4lf",PI*R*R);
}
606. 平均数1
读取两个浮点数 AA 和 BB 的值,对应于两个学生的成绩。
请你计算学生的平均分,其中 AA 的成绩的权重为 3.53.5,BB 的成绩的权重为 7.57.5。
成绩的取值范围在 00 到 1010 之间,且均保留一位小数。
输入格式
输入占两行,每行包含一个浮点数,第一行表示 AA,第二行表示 BB。
输出格式
输出格式为 MEDIA = X
,其中 XX 为平均分,结果保留五位小数。
数据范围
0≤A,B≤10.00≤A,B≤10.0
输入样例:
5.0
7.1
输出样例:
MEDIA = 6.43182
#include<cstdio>
using namespace std;
float A,B;
int main(){
scanf("%f%f",&A,&B);
printf("MEDIA = %.5f",(A*3.5+B*7.5)/11);
}
3 4
样例输出:
7
#include<iostream>
using namespace std;
int a,b,c ;
int main(){
cin>>a>>b>>c;
c=a+b;
cout<<c<<endl;
return 0;
}
1 学如逆水行舟,不进则退
边栏推荐
- How OpenGL works
- Apache DolphinScheduler, a new generation of distributed workflow task scheduling platform in practice - Medium
- Chinese characters to Pinyin
- 软链接引发的物理备份问题
- matlab绘制用颜色表示模值大小的箭头图
- 线上MySQL的自增id用尽怎么办?
- 02 【开发服务器 资源模块】
- J9数字货币论:web3的创作者经济是什么?
- Matlab map with color representation module value size arrow
- Regular expression to match a certain string in the middle
猜你喜欢
[C language] Detailed explanation of stacks and queues (define, destroy, and data operations)
DAY22:sqli-labs 靶场通关wp(Less01~~Less20)
J9数字货币论:web3的创作者经济是什么?
C语言日记 9 if的3种语句
Unleashing the engine of technological innovation, Intel joins hands with ecological partners to promote the vigorous development of smart retail
View handler 踩坑记录
Regular expression to match a certain string in the middle
VSCode Change Default Terminal 如何修改vscode的默认terminal
Using OpenVINO to implement the flying paddle version of the PGNet inference program
select tag custom style
随机推荐
RAID disk array
DAY22:sqli-labs 靶场通关wp(Less01~~Less20)
The 20th day of the special assault version of the sword offer
Apache DolphinScheduler, a new generation of distributed workflow task scheduling platform in practice - Medium
OpenGL 工作原理
编译预处理等细节
Cloud Native (32) | Introduction to Platform Storage System in Kubernetes
Error: Not a signal or slot declaration
线性表的查找
行业案例|世界 500 强险企如何建设指标驱动的经营分析系统
C学生管理系统 指定位置插入学生节点
Common hardware delays
线上MySQL的自增id用尽怎么办?
多线程(2)
1873. 计算特殊奖金
The 22-07-31 weeks summary
甘特图来啦,项目管理神器,模板直接用
2022了你还不会『低代码』?数据科学也能玩转Low-Code啦!
2022了你还不会『低代码』?数据科学也能玩转Low-Code啦!
What should I do if the self-incrementing id of online MySQL is exhausted?