当前位置:网站首页>Leetcode t1165: log analysis
Leetcode t1165: log analysis
2022-07-07 07:00:00 【Fan Qianzhi】
Log analysis
Title Description
M M M The shipping company recently needs to make statistics on the import and export of goods in its warehouses . At present, the only record they have is a log recording the entry and exit of containers . The log records two types of operations : The first type of operation is container warehousing , And the weight of the container in the warehouse ; The second type of operation is the outbound operation of containers . These records are in strict chronological order . The rules of container warehousing and outbound are first in and last out , That is, the containers to be delivered in each delivery operation are the latest containers to be delivered in the warehouse .
For analytical purposes , The analyst randomly inserts several third types of operations into the log ―― Query operation . When analyzing logs , Every query operation encountered , Report the weight of the largest container in the current warehouse .
Input format
contain N + 1 N+1 N+1 That's ok :
First act 1 1 1 A positive integer N N N, Corresponds to the total number of operations contained in the log .
Next $N $ That's ok , They belong to one of the following three formats :
Format 1 1 1: 0 X 0 X 0X // One container warehousing operation , Positive integer X X X Indicates the weight of the container in this warehouse
Format 2 2 2: 1 1 1 // One container outbound operation ,( For the time being ) The last container in the warehouse leaves the warehouse
Format 3 3 3: 2 2 2 // One query operation , The analyzer is required to output the weight of the largest container in the current warehouse
When the warehouse is empty, you should ignore the issue operation , When the warehouse is empty, you should output 0 0 0.
Output format
The number of output rows is equal to the number of query operations in the log . Each line is a positive integer , Represents the query result .
Examples #1
The sample input #1
13
0 1
0 2
2
0 4
0 2
2
1
2
1
1
2
1
2
Sample output #1
2
4
4
1
0
Tips
about 20 % 20\% 20% The data of , Yes N ≤ 10 N≤10 N≤10;
about 40 % 40\% 40% The data of , Yes N ≤ 1000 N≤1000 N≤1000;
about 100 % 100\% 100% The data of , Yes N ≤ 200000 , X ≤ 1 0 8 N≤200000,X≤10^8 N≤200000,X≤108.
Ideas
This problem is to maintain a stack a[], To achieve it Into the stack 、 Out of the stack 、 Query operation , To meet the requirements of the topic . This stack needs to meet a[i] From the bottom of the stack to i The largest of the elements .
- Push : When you stack an element x,t++,a[t] = max(a[t-1], x)
- Out of the stack :t–
- Inquire about : Output a[t]
The key that the above stack can meet the requirements of the topic is : If you enter an element x Not the largest in the current stack ( Suppose the biggest one is mx), That is, the element that entered before is larger , Then we don't care x What is the value of , Because until it is out of the stack , Will not be visited , Because the number of accesses will be output mx. Here's the picture :
also , The elements at the bottom of the stack are 0, Meet the requirements of the topic : Output when the warehouse is empty 0.
Code
#include<iostream>
#include<cmath>
using namespace std;
int a[200001], t = 0, y, n, ord;
int main() {
a[0] = 0;
cin >> n;
for(int i = 0; i < n; i++) {
cin >> ord;
if(ord == 0) {
cin >> y;
t+=1;
a[t] = max(a[t-1], y);
}
else if(ord == 1) {
if(t > 0) t-=1;
}
else cout << a[t] << endl;
}
return 0;
}
边栏推荐
- Big coffee gathering | nextarch foundation cloud development meetup is coming
- CompletableFuture使用详解
- 联合索引ABC的几种索引利用情况
- leetcode 509. Fibonacci Number(斐波那契数字)
- Can 7-day zero foundation prove HCIA? Huawei certification system learning path sharing
- Installing redis and windows extension method under win system
- 多个kubernetes集群如何实现共享同一个存储
- 栈题目:有效括号的嵌套深度
- 2018年江苏省职业院校技能大赛高职组“信息安全管理与评估”赛项任务书第一阶段答案
- 带你刷(牛客网)C语言百题(第一天)
猜你喜欢
MOS管参数μCox得到的一种方法
This article introduces you to the characteristics, purposes and basic function examples of static routing
Pinduoduo lost the lawsuit: "bargain for free" infringed the right to know but did not constitute fraud, and was sentenced to pay 400 yuan
ANR 原理及实践
Big coffee gathering | nextarch foundation cloud development meetup is coming
当前发布的SKU(销售规格)信息中包含疑似与宝贝无关的字
Stack and queue-p79-9
MATLAB小技巧(29)多项式拟合 plotfit
MATLAB小技巧(30)非线性拟合 lsqcurefit
Cloudcompare point pair selection
随机推荐
Several index utilization of joint index ABC
LVS+Keepalived(DR模式)学习笔记
学术报告系列(六) - Autonomous Driving on the journey to full autonomy
SolidWorks的GB库(钢型材库,包括铝型材、铝管等结构)安装及使用教程(生成铝型材为例)
MYSQL----导入导出&视图&索引&执行计划
Learning records on July 4, 2022
ESXI挂载移动(机械)硬盘详细教程
带你刷(牛客网)C语言百题(第一天)
2018年江苏省职业院校技能大赛高职组“信息安全管理与评估”赛项任务书第一阶段答案
Please tell me how to monitor multiple schemas and tables by listening to PgSQL
数据资产管理与数据安全国内外最新趋势
Unable to debug screen program with serial port
Redhat5 installing vmware tools under virtual machine
unity3d学习笔记
企業如何進行數據治理?分享數據治理4個方面的經驗總結
如何给目标机器人建模并仿真【数学/控制意义】
JWT certification
JWT的基础介绍
Networkx绘图和常用库函数坐标绘图
JESD204B时钟网络