当前位置:网站首页>Leetcode t1165: log analysis
Leetcode t1165: log analysis
2022-07-07 07:00:00 【Fan Qianzhi】
Log analysis
Title Description
M M M The shipping company recently needs to make statistics on the import and export of goods in its warehouses . At present, the only record they have is a log recording the entry and exit of containers . The log records two types of operations : The first type of operation is container warehousing , And the weight of the container in the warehouse ; The second type of operation is the outbound operation of containers . These records are in strict chronological order . The rules of container warehousing and outbound are first in and last out , That is, the containers to be delivered in each delivery operation are the latest containers to be delivered in the warehouse .
For analytical purposes , The analyst randomly inserts several third types of operations into the log ―― Query operation . When analyzing logs , Every query operation encountered , Report the weight of the largest container in the current warehouse .
Input format
contain N + 1 N+1 N+1 That's ok :
First act 1 1 1 A positive integer N N N, Corresponds to the total number of operations contained in the log .
Next $N $ That's ok , They belong to one of the following three formats :
Format 1 1 1: 0 X 0 X 0X // One container warehousing operation , Positive integer X X X Indicates the weight of the container in this warehouse
Format 2 2 2: 1 1 1 // One container outbound operation ,( For the time being ) The last container in the warehouse leaves the warehouse
Format 3 3 3: 2 2 2 // One query operation , The analyzer is required to output the weight of the largest container in the current warehouse
When the warehouse is empty, you should ignore the issue operation , When the warehouse is empty, you should output 0 0 0.
Output format
The number of output rows is equal to the number of query operations in the log . Each line is a positive integer , Represents the query result .
Examples #1
The sample input #1
13
0 1
0 2
2
0 4
0 2
2
1
2
1
1
2
1
2
Sample output #1
2
4
4
1
0
Tips
about 20 % 20\% 20% The data of , Yes N ≤ 10 N≤10 N≤10;
about 40 % 40\% 40% The data of , Yes N ≤ 1000 N≤1000 N≤1000;
about 100 % 100\% 100% The data of , Yes N ≤ 200000 , X ≤ 1 0 8 N≤200000,X≤10^8 N≤200000,X≤108.
Ideas
This problem is to maintain a stack a[], To achieve it Into the stack 、 Out of the stack 、 Query operation , To meet the requirements of the topic . This stack needs to meet a[i] From the bottom of the stack to i The largest of the elements .
- Push : When you stack an element x,t++,a[t] = max(a[t-1], x)
- Out of the stack :t–
- Inquire about : Output a[t]
The key that the above stack can meet the requirements of the topic is : If you enter an element x Not the largest in the current stack ( Suppose the biggest one is mx), That is, the element that entered before is larger , Then we don't care x What is the value of , Because until it is out of the stack , Will not be visited , Because the number of accesses will be output mx. Here's the picture :
also , The elements at the bottom of the stack are 0, Meet the requirements of the topic : Output when the warehouse is empty 0.
Code
#include<iostream>
#include<cmath>
using namespace std;
int a[200001], t = 0, y, n, ord;
int main() {
a[0] = 0;
cin >> n;
for(int i = 0; i < n; i++) {
cin >> ord;
if(ord == 0) {
cin >> y;
t+=1;
a[t] = max(a[t-1], y);
}
else if(ord == 1) {
if(t > 0) t-=1;
}
else cout << a[t] << endl;
}
return 0;
}
边栏推荐
- 网络基础 —— 报头、封装和解包
- 使用TCP/IP四层模型进行网络传输的基本流程
- 数据资产管理与数据安全国内外最新趋势
- dolphinscheduler3. X local startup
- Prompt for channel security on the super-v / device defender side when installing vmmare
- RuntimeError: CUDA error: CUBLAS_STATUS_ALLOC_FAILED when calling `cublasCreate(handle)`问题解决
- ESXI挂载移动(机械)硬盘详细教程
- MYSQL----导入导出&视图&索引&执行计划
- Installing redis and windows extension method under win system
- 关于数据库数据转移的问题,求各位解答下
猜你喜欢
Abnova 免疫组化服务解决方案
LC 面试题 02.07. 链表相交 & LC142. 环形链表II
大促过后,销量与流量兼具,是否真的高枕无忧?
Cloudcompare point pair selection
Can't you really do it when you are 35 years old?
二十岁的我4面拿到字节跳动offer,至今不敢相信
Matlab tips (29) polynomial fitting plotfit
LVS+Keepalived(DR模式)学习笔记
How can gyms improve their competitiveness?
Abnova 膜蛋白脂蛋白体技术及类别展示
随机推荐
sqlserver多线程查询问题
使用TCP/IP四层模型进行网络传输的基本流程
CompletableFuture使用详解
多线程与高并发(9)——AQS其他同步组件(Semaphore、ReentrantReadWriteLock、Exchanger)
分布式id解决方案
毕业设计游戏商城
Answer to the first stage of the assignment of "information security management and evaluation" of the higher vocational group of the 2018 Jiangsu Vocational College skills competition
多学科融合
根据IP获取地市
Programmers' daily | daily anecdotes
Unable to debug screen program with serial port
如何给目标机器人建模并仿真【数学/控制意义】
Bus message bus
MySql用户权限
from .onnxruntime_pybind11_state import * # noqa ddddocr运行报错
Config分布式配置中心
Several index utilization of joint index ABC
「运维有小邓」符合GDPR的合规要求
Big coffee gathering | nextarch foundation cloud development meetup is coming
JWT的基础介绍