当前位置:网站首页>DP: tree DP
DP: tree DP
2022-07-05 19:58:00 【Full stack programmer webmaster】
Hello everyone , I meet you again , I'm the king of the whole stack , I've prepared for you today Idea Registration code .
The more, The Better
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5414 Accepted Submission(s): 3217
Problem Description
ACboy I like playing a strategy game very much , On a map , Yes N A castle . Every castle has a certain treasure , In every game ACboy Agree to conquer M Build a castle and get the treasures inside . But because of the geographical location . Some castles cannot be conquered directly , To conquer these castles, you must first conquer a specific Castle . You can help ACboy Figure out which treasure to conquer if you want to get as many as possible M A castle ?
Input
Each test case first contains 2 It's an integer ,N,M.(1 <= M <= N <= 200); In the following N line . Each row contains 2 It's an integer .a,b. In the i That's ok ,a It means to conquer the i A castle must be conquered first a A castle , hypothesis a = 0 Then it means that you can directly overcome the i A castle .
b On behalf of the i The number of treasures in a castle , b >= 0. When N = 0, M = 0 End of input .
Output
For each test case . Output an integer . representative ACboy Conquered M The number of treasures obtained by the castle .
Sample Input
3 2
0 1
0 2
0 3
7 4
2 2
0 1
0 4
2 1
7 1
7 6
2 2
0 0
Sample Output
5
13
dp[i][j] Said to i Root node j Maximum value of child nodes .#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<vector>
typedef long long LL;
using namespace std;
const int maxn=220;
int v[maxn];
int n,m;
int dp[maxn][maxn];
vector<int>s[maxn];
void tree_dp(int n,int f)
{
int len=s[n].size();
dp[n][1]=v[n];
for(int i=0;i<len;i++)
{
if(f>1) tree_dp(s[n][i],f-1);
for(int j=f;j>=1;j--)
{
for(int k=1;k<=j;k++)
dp[n][j+1]=max(dp[n][j+1],dp[n][j+1-k]+dp[s[n][i]][k]);
}
}
}
int main()
{
int f;
while(~scanf("%d%d",&n,&m)&&(n+m))
{
v[0]=0;
memset(dp,0,sizeof(dp));
for(int i=0;i<=n;i++)
s[i].clear();
for(int i=1;i<=n;i++)
{
scanf("%d%d",&f,&v[i]);
s[f].push_back(i);
}
tree_dp(0,m+1);
printf("%d\n",dp[0][m+1]);
}
return 0;
}
Anniversary party
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4329
Accepted: 2463
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
const int maxn=6005;
int dp[maxn][2],pre[maxn];
int visit[maxn],n;
void tree_dp(int x)
{
visit[x]=1;
for(int i=1;i<=n;i++)
{
// cout<<"111 "<<i<<endl;
if(!visit[i]&&pre[i]==x)
{
tree_dp(i);
dp[x][1]+=dp[i][0];
dp[x][0]+=max(dp[i][1],dp[i][0]);
}
}
}
int main()
{
while(~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
memset(visit,0,sizeof(visit));
memset(pre,0,sizeof(pre));
for(int i=1;i<=n;i++)
scanf("%d",&dp[i][1]);
int x,y,root;
while(~scanf("%d%d",&x,&y)&&(x+y))
{
pre[x]=y;
root=y;
}
while(pre[root])
root=pre[root];
// cout<<"fuck "<<root<<endl;
tree_dp(root);
printf("%d\n",max(dp[root][0],dp[root][1]));
}
return 0;
}
Publisher : Full stack programmer stack length , Reprint please indicate the source :https://javaforall.cn/117734.html Link to the original text :https://javaforall.cn
边栏推荐
- Worthy of being a boss, byte Daniel spent eight months on another masterpiece
- Android interview classic, 2022 Android interview written examination summary
- Gstreamer中的task
- CADD课程学习(7)-- 模拟靶点和小分子相互作用 (半柔性对接 AutoDock)
- What does software testing do? What are the requirements for learning?
- Inventory of the most complete low code / no code platforms in the whole network: Jiandao cloud, partner cloud, Mingdao cloud, Qingliu, xurong cloud, Jijian cloud, treelab, nailing · Yida, Tencent clo
- 随机数生成的四种方法|Random|Math|ThreadLocalRandom|SecurityRandom
- 浅浅的谈一下ThreadLocalInsecureRandom
- ffplay文档[通俗易懂]
- 完爆面试官,一线互联网企业高级Android工程师面试题大全
猜你喜欢
leetcode刷题:二叉树10(完全二叉树的节点个数)
【硬核干货】数据分析哪家强?选Pandas还是选SQL
Webuploader file upload drag upload progress monitoring type control upload result monitoring control
S7-200SMART利用V90 MODBUS通信控制库控制V90伺服的具体方法和步骤
How about testing outsourcing companies?
Build your own website (16)
建议收藏,我的腾讯Android面试经历分享
Force buckle 729 My schedule I
Database logic processing function
redis集群模拟消息队列
随机推荐
aggregate
Android interview classic, 2022 Android interview written examination summary
C langue OJ obtenir PE, ACM démarrer OJ
c——顺序结构
Is it safe to open a mobile stock account? Is it reliable?
ICTCLAS用的字Lucene4.9捆绑
Debezium series: idea integrates lexical and grammatical analysis ANTLR, and check the DDL, DML and other statements supported by debezium
力扣 729. 我的日程安排表 I
Microwave radar induction module technology, real-time intelligent detection of human existence, static micro motion and static perception
随机数生成的四种方法|Random|Math|ThreadLocalRandom|SecurityRandom
Base du réseau neuronal de convolution d'apprentissage profond (CNN)
Based on vs2017 and cmake GUI configuration, zxing and opencv are used in win10 x64 environment, and simple detection of data matrix code is realized
third-party dynamic library (libcudnn.so) that Paddle depends on is not configured correctl
CADD课程学习(7)-- 模拟靶点和小分子相互作用 (半柔性对接 AutoDock)
What is the function of okcc call center
sun.misc.BASE64Encoder报错解决方法[通俗易懂]
No matter how busy you are, you can't forget safety
Analysis of openh264 decoded data flow
Go language | 03 array, pointer, slice usage
SecureRandom那些事|真伪随机数