当前位置:网站首页>暑假刷题嗷嗷嗷嗷
暑假刷题嗷嗷嗷嗷
2022-07-06 09:30:00 【牙疼想吃桃】
因为最近的工作内容不涉及编程
我已经很久很久很久没有敲过代码了
现在因为学校课程
要快速回顾一下啦
考试一时爽
上学泪两行
加上十月份还有体测
最近还有各种运动比赛
啊啊啊啊啊啊啊啊啊啊加油吧
第一题
题目:
计算两个32位整数A和B的和!
输入 输入数据有多组,每组为一行,包括两个不超过二进制32位的整数。
输出 对每组输入,在单独的行中输出结果。
示例输入
1 2
-1 1
示例输出
3
0
注意点:极限输入
#include<stdio.h>
int main()
{
long a, b;
while(scanf("%ld %ld", &a, &b)!=EOF)
{
printf("%ld\n", a+b);
}
return 0;
}
第二题
题目:
计算两个32位整数A和B的和!
输入 输入数据的第一行为一个整数TT,表示有TT组数据。随后的TT行中,每行有两个整数A和B。
输出 对每组输入,在单独的行中输出结果。
示例输入
2
1 2
-1 1
示例输出
3
0
注意点:
Scanner是SDK1.5新增的一个类,可使用该类创建一个对象。
Scanner input=new Scanner(System.in);
input可以调用nextInt()、next()、nextLine()等方法
nextInt(): it only reads the int value, nextInt() places the cursor in
the same line after reading the input.next(): read the input only till the space. It can’t read two words
separated by space. Also, next() places the cursor in the same line
after reading the input.(一般用于字符串)nextLine(): reads input including space between the words (that is,
it reads till the end of line \n). Once the input is read, nextLine()
positions the cursor in the next line.
import java.util.Scanner;
public class Main {
public static void main(final String[] args) {
Scanner sc = new Scanner(System.in);
int T = sc.nextInt();
long a, b;
for (int i = 0; i < T; i++) {
//每一行只有两个数
a = sc.nextInt();
b = sc.nextInt();
System.out.println(a + b);
}
sc.close();
}
}
第三题
题目:
计算两个32位整数A和B的和!
输入 输入数据有多组,每组为一行,包括两个32位整数。若两个整数均为0,表示输入结束。
输出 对每组输入,在单独的行中输出结果。
示例输入
1 2
-1 1
0 0
示例输出
3
0
注意点:
判断条件
import java.util.Scanner;
public class input3 {
public static void main(final String[] args) {
final Scanner sc = new Scanner(System.in);
long a, b;
a = sc.nextInt();
b = sc.nextInt();
while (a != 0 || b != 0){
System.out.println(a + b);
a = sc.nextInt();
b = sc.nextInt();
}
sc.close();
}
}
第四题
题目
若干32位整数求和。
输入
输入数据有多组,每组为一行,包括若干个32位整数。行首数字为该行中后续数字的个数,若行首的数值为0,表示输入结束。输出
对每组输入,在单独的行中输出结果。示例输入
5 1 2 3 4 5
2 -1 1
0
示例输出
15
0
注意点:
每一行不止有两个数据,多行数据
#include <stdio.h>
int main()
{
long long int a, b, c = 0;
char d;
while (scanf("%lld", &a), a != 0)
{
while (d = getchar(), d != '\n')
{
scanf("%lld", &b);
c += b;
}
printf("%lld\n", c);
c = 0;
}
return 0;
}
第五题
题目
若干32位整数求和。
输入
输入数据的第一行为一个整数TT,表示有TT组测试数据,每组为一行。随后的TT行中,每行第一个数为一个整数NN,随后有NN个32位整数。
输出
对每组输入,在单独的行中输出结果。
示例输入
3
5 1 2 3 4 5
2 -1 1
1 0
示例输出
15
0
0
边栏推荐
- 字节跳动多篇论文入选 CVPR 2021,精选干货都在这里了
- 我走過最迷的路,是字節跳動程序員的腦回路
- 字节跳动2022校招研发提前批宣讲会,同学们最关心的10个问题
- The "advertising maniacs" in this group of programmers turned Tiktok advertisements into ar games
- À propos de l'utilisation intelligente du flux et de la carte
- DOS 功能调用
- Conception du système de thermomètre numérique DS18B20
- TypeScript基本操作
- ~83 form introduction
- Fdog series (V): use QT to imitate QQ to realize login interface to main interface, function chapter.
猜你喜欢
MySQL字符串函数
~Introduction to form 80
Alibaba cloud server builds SVN version Library
Fdog series (4): use the QT framework to imitate QQ to realize the login interface, interface chapter.
Activiti目录(四)查询代办/已办、审核
Shell_ 03_ environment variable
Activit零零碎碎要人命的坑
Fdog series (V): use QT to imitate QQ to realize login interface to main interface, function chapter.
8086 CPU internal structure
Some instructions on whether to call destructor when QT window closes and application stops
随机推荐
Assembly language addressing mode
arithmetic operation
ByteDance 2022 school recruitment R & D advance approval publicity meeting, students' top 10 issues
DOS function call
@RestController、@Controller
Data transfer instruction
~75 background
面试集锦库
Ruoyi-Cloud 踩坑的BUG
yum install xxx报错
8086 CPU 内部结构
Login to verify the simple use of KOA passport Middleware
When it comes to Google i/o, this is how ByteDance is applied to flutter
关于Stream和Map的巧用
Only learning C can live up to expectations top5 S1E8 | S1E9: characters and strings & arithmetic operators
DS18B20數字溫度計系統設計
Basic knowledge of assembly language
Ce n'est qu'en apprenant que c est à la hauteur des attentes Top5 s1e8 | s1e9: caractères et chaînes & opérateurs arithmétiques
The "advertising maniacs" in this group of programmers turned Tiktok advertisements into ar games
Logical operation instruction