当前位置:网站首页>POJ2031空间站题解
POJ2031空间站题解
2022-08-01 07:05:00 【bj_hacker】
题目
链接
http://poj.org/problem?id=2031
字面描述
Building a Space Station
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21441 Accepted: 9383
Description
You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.
All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor’, or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.
You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.
You can ignore the width of a corridor. A corridor is built between points on two cells’ surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.
Input
The input consists of multiple data sets. Each data set is given in the following format.
n
x1 y1 z1 r1
x2 y2 z2 r2
…
xn yn zn rn
The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.
The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.
Each of x, y, z and r is positive and is less than 100.0.
The end of the input is indicated by a line containing a zero.
Output
For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.
Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.
Sample Input
3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0
Sample Output
20.000
0.000
73.834
Source
Japan 2003 Domestic
代码描述
模板
#include<cstdio>
#include<cstring>
#include<string.h>
#include<cmath>
using namespace std;
const int maxn=100+10;
const double inf=2e9;
int n;
double ans;
double x[maxn],y[maxn],z[maxn],r[maxn],lowcost[maxn];
double g[maxn][maxn];
bool vis[maxn];
//欧氏距离
inline double dis(double x1,double y1,double z1,double x2,double y2,double z2){
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)+(z1-z2)*(z1-z2));
}
inline void Prim(){
//初始化
memset(vis,false,sizeof(vis));
ans=0;
vis[1]=true;
for(int i=1;i<=n;i++)lowcost[i]=g[1][i];
//n-1条边的添加
for(int i=1;i<n;i++){
double temp=inf;
int t=1;
//寻找离已添加最近的节点t
for(int j=1;j<=n;j++){
if(!vis[j]&&lowcost[j]<temp){
temp=lowcost[j];
t=j;
}
}
ans+=temp;
if(t==1)break;
vis[t]=true;
//更新未添加节点
for(int j=1;j<=n;j++){
if(!vis[j]&&g[t][j]<lowcost[j])lowcost[j]=g[t][j];
}
}
}
int main(){
while(1){
scanf("%d",&n);
if(!n)break;
for(int i=1;i<=n;i++)scanf("%lf%lf%lf%lf",&x[i],&y[i],&z[i],&r[i]);
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
double op=dis(x[i],y[i],z[i],x[j],y[j],z[j]);
if(op<=r[i]+r[j]){
g[i][j]=0;
g[j][i]=0;
}
else {
g[i][j]=op-r[i]-r[j];
g[j][i]=op-r[i]-r[j];
}
}
}
Prim();
printf("%.3lf\n",ans);
}
return 0;
}
边栏推荐
猜你喜欢
随机推荐
Three aspects of Ali: How to solve the problem of MQ message loss, duplication and backlog?
crypto-js uses
表的创建、修改与删除
Dart exception details
Introduction to the basic principles, implementation and problem solving of crawler
太厉害了,终于有人能把文件上传漏洞讲的明明白白了
uva12326
LeetCode240+312+394
I have three degrees, and I have five faces. I was "confessed" by the interviewer, and I got an offer of 33*15.
How JS works
NUMPY
小程序通过云函数操作数据库【使用get取数据库】
对于升级go1.18的goland问题
Dell PowerEdge Server R450 RAID Configuration Steps
升级为重量级锁,锁重入会导致锁释放?
信息系统项目管理师必背核心考点(五十六)配置控制委员会(CCB)的工作
R语言使用gt包和gtExtras包优雅地、漂亮地显示表格数据:gtExtras包的pad_fn函数与gt::fmt函数一起用于填充包含数值的特定列、对数据列的数值进行十进制对齐(从小数点对齐)
weight distribution
Fist game copyright-free music download, League of Legends copyright-free music, can be used for video creation, live broadcast
return; represents meaning