当前位置:网站首页>PAT乙级-B1021 个位数统计(15)
PAT乙级-B1021 个位数统计(15)
2022-08-05 09:05:00 【nekoha_dexter】
给定一个 k 位整数 N=dk−110k−1+⋯+d1101+d0 (0≤di≤9, i=0,⋯,k−1, dk−1>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定 N=100311,则有 2 个 0,3 个 1,和 1 个 3。
输入格式:
每个输入包含 1 个测试用例,即一个不超过 1000 位的正整数 N。
输出格式:
对 N 中每一种不同的个位数字,以 D:M
的格式在一行中输出该位数字 D
及其在 N 中出现的次数 M
。要求按 D
的升序输出。
输入样例:
100311
输出样例:
0:2
1:3
3:1
#include<iostream>
#include<map>
using namespace std;
int main(){
string s;
cin >> s;
//记录各个位的个数
map<char, int> mp;
for(int i = 0; i < s.size(); ++i)
mp[s[i]]++;
//输出
for(auto it = mp.begin(); it != mp.end(); ++it)
cout << it->first << ":"<<it->second<<endl;
return 0;
}
边栏推荐
- 科普大佬说 | 港大黄凯斌老师带你解锁黑客帝国与6G的关系
- XCODE12 在使用模拟器(SIMULATOR)时编译错误的解决方法
- seata源码解析:事务状态及全局锁的存储
- 浅谈自动采集程序及入库
- How to replace colors in ps, self-study ps software photoshop2022, replace one color of a picture in ps with another color
- 六年团队Leader实战秘诀|程序员最重要的八种软技能 - 脸皮薄容易耽误事 - 自我营销
- Why is pnpm hitting npm and yarn dimensionality reduction?
- 随时牵手 不要随意分手[转帖]
- flink cdc支持从oracle dg库同步吗
- egg framework
猜你喜欢
How to replace colors in ps, self-study ps software photoshop2022, replace one color of a picture in ps with another color
spark集群部署(第三弹)
网页直接访问链接不让安全中心拦截
seata源码解析:事务状态及全局锁的存储
汇编语言(8)x86内联汇编
全面讲解GET 和 POST请求的本质区别是什么?原来我一直理解错了
营销建议 | 您有一份八月营销月历待查收! 建议收藏 !
Why do I recommend using smart async?
How to make a puzzle in PS, self-study PS software photoshop2022, PS make a puzzle effect
Chapter 12 Bayesian Networks
随机推荐
The difference between beautiful MM and ordinary MM
JS syntax usage
ts/js function pass parameter with function writing
并发之CAS
mySQL数据库初始化失败,有谁可以指导一下吗
宝塔实测-搭建中小型民宿酒店管理源码
sql server中 两表查询 平均数 分组
Pagoda measurement - building small and medium-sized homestay hotel management source code
十一道家常小菜详细攻略[图文并茂]
Chapter 12 Bayesian Networks
Comprehensively explain what is the essential difference between GET and POST requests?Turns out I always misunderstood
Undefined symbols for architecture arm64解决方案
工程制图试题
链表中的数字相加----链表专题
【零基础玩转BLDC系列】无刷直流电机无位置传感器三段式启动法详细介绍及代码分享
leetcode 剑指 Offer 10- I. 斐波那契数列
Code Audit - PHP
my journal link
线程之Happens-before规则
There is only one switch, how to realize the nqa of master-slave automatic switching