当前位置:网站首页>Tree of life (tree DP)
Tree of life (tree DP)
2022-07-06 16:25:00 【AC__ dream】
Data range
1≤n≤10^5,
The absolute value of the score of each node shall not exceed 10^6.
sample input :
5
1 -2 -3 4 5
4 2
3 1
1 2
2 5
sample output :
8
analysis : This question is for us Find the biggest link in the tree , We can Definition f[i] For i Is the value of the largest pass block in the subtree of the root , The result is f[1~n] Maximum of , Tree form DP The process is relatively simple , At first it made f[i]=w[i], That is to make this connected block contain only its own point , Then, as long as the value of the largest pass block in the subtree with the child node as the root is greater than 0, Just add , Follow this dp You can find the answer , Detail reference code :
#include<cstdio>
#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
#include<map>
#include<cmath>
#include<queue>
using namespace std;
#define int long long
const int N=1e5+10;
int w[N*2],f[N],e[N*2],ne[N*2],h[N],idx;//f[i] Said to i Is the maximum value in the connected block of the root
void add(int x,int y)
{
e[idx]=y;
ne[idx]=h[x];
h[x]=idx++;
}
int dp(int x,int father)
{
f[x]=w[x];
for(int i=h[x];i!=-1;i=ne[i])
{
int j=e[i];
if(j==father) continue;
f[x]+=max(dp(j,x),(int)0);
}
return f[x];
}
signed main()
{
int n;
cin>>n;
for(int i=1;i<=n;i++)
scanf("%lld",&w[i]);
memset(h,-1,sizeof h);
for(int i=1;i<n;i++)
{
int u,v;
scanf("%lld%lld",&u,&v);
add(u,v);add(v,u);
}
dp(1,0);
int ans=-0x3f3f3f3f;
for(int i=1;i<=n;i++)
ans=max(ans,f[i]);
printf("%lld",ans);
return 0;
}
边栏推荐
- 1855. Maximum distance of subscript alignment
- AcWing——第55场周赛
- (POJ - 2739) sum of constructive prime numbers (ruler or two points)
- 栈的经典应用—括号匹配问题
- Codeforces Round #799 (Div. 4)A~H
- Programmers, what are your skills in code writing?
- Vs2019 initial use
- Date plus 1 day
- Sword finger offer II 019 Delete at most one character to get a palindrome
- 分享一个在树莓派运行dash应用的实例。
猜你喜欢
Browser print margin, default / borderless, full 1 page A4
Codeforces Round #797 (Div. 3)无F
B - Code Party (girls' competition)
本地可视化工具连接阿里云centOS服务器的redis
1903. Maximum odd number in string
Programmers, what are your skills in code writing?
969. Pancake sorting
The concept of C language array
Flask框架配置loguru日志庫
Advancedinstaller installation package custom action open file
随机推荐
Write web games in C language
Openwrt source code generation image
Basic Q & A of introductory C language
QT实现圆角窗口
It is forbidden to trigger onchange in antd upload beforeupload
Effet d'utilisation, déclenché lorsque les composants de la fonction sont montés et déchargés
QT按钮点击切换QLineEdit焦点(含代码)
(POJ - 3258) River hopper (two points)
C language must memorize code Encyclopedia
Codeforces Round #803 (Div. 2)A~C
1529. Minimum number of suffix flips
1855. Maximum distance of subscript alignment
Programmers, what are your skills in code writing?
QT实现窗口渐变消失QPropertyAnimation+进度条
useEffect,函數組件掛載和卸載時觸發
Opencv learning log 24 -- Hough transform 2 (maximum interval and minimum length can be limited)
Browser print margin, default / borderless, full 1 page A4
Pytorch extract skeleton (differentiable)
Install Jupiter notebook under Anaconda
Acwing - game 55 of the week