当前位置:网站首页>PAT乙级-B1020 月饼(25)
PAT乙级-B1020 月饼(25)
2022-08-05 09:05:00 【nekoha_dexter】
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。
输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。
输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct stuff{ //不能命名为data
float storage, total, price;
} ;
vector<stuff> mooncake;
//单价高优先,单价相同存量多优先
bool cmp(stuff a, stuff b){
return a.price != b.price? a.price > b.price : a.storage > b.storage;
}
int main(){
int n, d;//种类、需求量,且均为正整数
cin >> n >> d;
mooncake.resize(n);
for(int i = 0; i < n; ++i)
cin >> mooncake[i].storage;
for(int i = 0;i < n; ++i){
cin >> mooncake[i].total;
mooncake[i].price = mooncake[i].total / mooncake[i].storage;
}
sort(mooncake.begin(), mooncake.end(), cmp);
float ans = 0;
for(int i = 0; i < n; ++i){
//当库存>=需求时,
if(mooncake[i].storage >= d){
ans += mooncake[i].price * d;
break;
}
ans += mooncake[i].total;
d -= mooncake[i].storage;
}
printf("%.2f", ans);
return 0;
}
边栏推荐
- 让硬盘更快,让系统更稳定
- CROS and JSONP configuration
- 树状数组模版+例题
- What is a good movie to watch on Qixi Festival?Crawl movie ratings and save to csv file
- 使用HBuilder离线本地打包ipa教程
- 动态内存开辟(C语言)
- 按钮上显示值的轮流切换
- Creo 9.0 基准特征:基准点
- Neuron Newsletter 2022-07|新增非 A11 驱动、即将支持 OPC DA
- Xcode 12 ld: symbol(s) not found for architecture armv64
猜你喜欢
苹果官网商店新上架Mophie系列Powerstation Pro、GaN充电头等产品
最 Cool 的 Kubernetes 网络方案 Cilium 入门教程
工程制图试题
C语言-数组
The Coolest Kubernetes Network Solution Cilium Getting Started Tutorial
Assembly language (8) x86 inline assembly
使用HBuilder离线本地打包ipa教程
原型&原型链
XCODE12 在使用模拟器(SIMULATOR)时编译错误的解决方法
Redis cache and existing problems--cache penetration, cache avalanche, cache breakdown and solutions
随机推荐
基于 Kubernetes 的微服务项目整体设计与实现
There is only one switch, how to realize the nqa of master-slave automatic switching
DNS 查询原理详解
国际原子能机构总干事称乌克兰扎波罗热核电站安全形势堪忧
随时牵手 不要随意分手[转帖]
8.4 Summary of the mock competition
The Coolest Kubernetes Network Solution Cilium Getting Started Tutorial
【LeetCode】623. 在二叉树中增加一行
MySQL内部函数介绍
ECCV 2022 Oral 视频实例分割新SOTA:SeqFormer&IDOL及CVPR 2022 视频实例分割竞赛冠军方案...
DPU — 功能特性 — 安全系统的硬件卸载
放大器OPA855的噪声计算实例
Luogu: P2574 XOR的艺术 [线段树]
tensorflow.keras cannot introduce layers
What is the connection and difference between software system testing and acceptance testing? Professional software testing solution recommendation
openpyxl to manipulate Excel files
工程制图试题
使用HBuilder离线本地打包ipa教程
selectPage 动态改变参数方法
ECCV 2022 Oral Video Instance Segmentation New SOTA: SeqFormer & IDOL and CVPR 2022 Video Instance Segmentation Competition Champion Scheme...