当前位置:网站首页>杭州电 3711 Binary Number
杭州电 3711 Binary Number
2022-07-06 21:26:00 【全栈程序员站长】
大家好,又见面了,我是全栈君
Binary Number
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1287 Accepted Submission(s): 807
Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
Output
For each test case you should output n lines, each of which contains the result for each query in a single line.
Sample Input
2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353
Sample Output
1
2
1
1
1
9999
0
AC代码例如以下:
#include <stdio.h>
int a[105];
int count(int x)
{
int c = 0;
for(;x;x>>=1) if(x&1) c++;
return c;
}
int main()
{
int b, i, j, n, m, k, min, t,cases;
scanf("%d",&cases);
while(cases--)
{
scanf("%d%d",&n,&m);
for(i=0; i<n; i++) scanf("%d",&a[i]);
for(i=0; i<m; i++)
{
scanf("%d",&b);
min = count(b^a[0]);
k = 0;
for(j=1; j<n; j++)
{
t = count(b^a[j]);
if(t<min||t==min&&a[j]<a[k])
{ min = t;k = j;}
}
printf("%d\n",a[k]);
}
}
return 0;
}
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/116703.html原文链接:https://javaforall.cn
边栏推荐
猜你喜欢
qt-线程等01概念
我的勇敢对线之路--详细阐述,浏览器输入URL发生了什么
QT 项目 表格新建列名称设置 需求练习(找数组消失的数字、最大值)
[development software] tilipa Developer Software
卡尔曼滤波-1
VHDL implementation of arbitrary size matrix addition operation
Construction of Hisilicon universal platform: color space conversion YUV2RGB
【DPDK】dpdk样例源码解析之三:dpdk-l3fwd_001
23. (ArcGIS API for JS) ArcGIS API for JS ellipse collection (sketchviewmodel)
leetcode:面试题 17.24. 子矩阵最大累加和(待研究)
随机推荐
再AD 的 界面顶部(菜单栏)创建常用的快捷图标
Delete data in SQL
Tencent cloud native database tdsql-c was selected into the cloud native product catalog of the Academy of communications and communications
Adaptive non European advertising retrieval system amcad
Que savez - vous de la sérialisation et de l'anti - séquence?
25. (ArcGIS API for JS) ArcGIS API for JS line modification line editing (sketchviewmodel)
【安全攻防】序列化與反序列,你了解多少?
opencv第三方库
Native MySQL
Summer 2022 daily question 1 (1)
The most complete learning rate adjustment strategy in history LR_ scheduler
Vernacular high concurrency (2)
Preprocessing - interpolation
Class常量池与运行时常量池
About Tolerance Intervals
未来发展路线确认!数字经济、数字化转型、数据...这次会议很重要
Search of linear table
如何检测mysql代码运行是否出现死锁+binlog查看
map和set的实现
史上最全学习率调整策略lr_scheduler