当前位置:网站首页>杭州电 3711 Binary Number
杭州电 3711 Binary Number
2022-07-06 21:26:00 【全栈程序员站长】
大家好,又见面了,我是全栈君
Binary Number
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1287 Accepted Submission(s): 807
Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
Output
For each test case you should output n lines, each of which contains the result for each query in a single line.
Sample Input
2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353
Sample Output
1
2
1
1
1
9999
0
AC代码例如以下:
#include <stdio.h>
int a[105];
int count(int x)
{
int c = 0;
for(;x;x>>=1) if(x&1) c++;
return c;
}
int main()
{
int b, i, j, n, m, k, min, t,cases;
scanf("%d",&cases);
while(cases--)
{
scanf("%d%d",&n,&m);
for(i=0; i<n; i++) scanf("%d",&a[i]);
for(i=0; i<m; i++)
{
scanf("%d",&b);
min = count(b^a[0]);
k = 0;
for(j=1; j<n; j++)
{
t = count(b^a[j]);
if(t<min||t==min&&a[j]<a[k])
{ min = t;k = j;}
}
printf("%d\n",a[k]);
}
}
return 0;
}
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/116703.html原文链接:https://javaforall.cn
边栏推荐
- AVL树插入操作与验证操作的简单实现
- 使用 BR 备份 TiDB 集群到 GCS
- 三重半圆环进度条,直接拿去就能用
- MySQL的存储引擎
- List interview common questions
- [security attack and Defense] how much do you know about serialization and deserialization?
- 机器学习笔记 - 使用机器学习进行鸟类物种分类
- Binary, octal, hexadecimal
- The most complete learning rate adjustment strategy in history LR_ scheduler
- map和set的实现
猜你喜欢
Force buckle ----- path sum III
ABAP 動態內錶分組循環
What is the experience of maintaining Wanxing open source vector database
【安全攻防】序列化与反序列,你了解多少?
QT 使用QToolTip 鼠标放上去显示文字时会把按钮的图片也显示了、修改提示文字样式
VHDL implementation of arbitrary size matrix multiplication
Gpt-3 is a peer review online when it has been submitted for its own research
1.19.11.SQL客户端、启动SQL客户端、执行SQL查询、环境配置文件、重启策略、自定义函数(User-defined Functions)、构造函数参数
Storage of data
Probability formula
随机推荐
API data interface of A-share index component data
Implementation of binary search tree
Mobile measurement and depth link platform - Branch
tflite模型转换和量化
ABAP 動態內錶分組循環
Baidu map JS development, open a blank, bmapgl is not defined, err_ FILE_ NOT_ FOUND
How to manage the expiration of enterprise distribution certificates- How to manage Enterprise Distribution certificate expiration?
When QT uses qtooltip mouse to display text, the picture of the button will also be displayed and the prompt text style will be modified
1.19.11.SQL客户端、启动SQL客户端、执行SQL查询、环境配置文件、重启策略、自定义函数(User-defined Functions)、构造函数参数
QT thread and other 01 concepts
qt-线程等01概念
SSL certificate deployment
Vernacular high concurrency (2)
Top 50 hit industry in the first half of 2022
24. (ArcGIS API for JS) ArcGIS API for JS point modification point editing (sketchviewmodel)
Some thoughts on cross end development of kbone and applet
23. (ArcGIS API for JS) ArcGIS API for JS ellipse collection (sketchviewmodel)
Termux set up the computer to connect to the mobile phone. (knock the command quickly), mobile phone termux port 8022
学习使用js把两个对象合并成一个对象的方法Object.assign()
ABAP Dynamic Inner table Group cycle