当前位置:网站首页>-角谷猜想-
-角谷猜想-
2022-08-03 05:10:00 【-JMY-】
题目描述
角谷猜想又称冰雹猜想。它首先流传于美国,不久传到欧洲,后来由一位叫角谷的日本人带到亚洲。因此被称为角谷猜想。
通俗地讲,角谷猜想的内容是这样的:任意给定一个自然数n,当n是偶数时,将它除以2,即将它变成n/2;当n是奇数时,就将它变成3n+1,……,若干步后,总会得到1。
在上述演变过程中,将每一次出现的数字排列起来,就会出现一个数字序列。
我们现在要解决的问题是:对于给定的n,求出数字序列中第一次出现1的位置。
输入
输入一个自然数n。1<=n<2^31
输出
输出序列中第一次出现1的位置。
样例输入
6
样例输出
9
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main(){
int n;
cin>>n;
for(int i=1;;i++){
if(n==1){
cout<<i;
return 0;
}
if(n%2==0)
n/=2;
else
n=3*n+1;
}
}
边栏推荐
- Js学习笔记(四)
- Interface Test Framework Practice (4) | Get Schema Assertion
- dataframe插入一列
- -最高分-
- Install IIS services (Internet Information Services (Internet Information Services, abbreviated IIS, Internet Information Services)
- ss-2.子项目互相访问(order80 -> payment8001)
- Common lipophilic cell membrane dyes DiO, Dil, DiR, Did spectrograms and experimental procedures
- User password verification
- Junit
- Create a tree structure
猜你喜欢
VSO Downloader Ultimate 5.0.1.45 中文多语免费版 在线视频下载工具
第三次HarmonyOS培训
轨迹(形状)相似性判断与度量方法
Peptides mediated PEG DSPE of phospholipids, targeted functional materials - PEG - RGD/TAT/NGR/APRPG
VR全景展打造专属元宇宙观展空间
阿里云对象存储oss私有桶生成链接
Harmony OS Date ano UI 】 【 】 the basic operation
Apache DolphinScheduler版本2.0.5分布式集群的安装
idea使用@Autowired注解爆红原因及解决方法
Detailed explanation of MOSN reverse channel
随机推荐
Install IIS services (Internet Information Services (Internet Information Services, abbreviated IIS, Internet Information Services)
web安全-sql注入漏洞
背压机制
Modelarts第一次培训
1054 求平均值 (20 分)
Fluorescent marker peptides FITC/AMC/FAM/Rhodamine TAMRA/Cy3 / Cy5 / Cy7 - Peptide
Coordinate knowledge in digital twin campus scenarios
-整数求和-
-查找数-
Benchmark 第一篇 了解Benchmark
Apache DolphinScheduler版本2.0.5分布式集群的安装
Get the Ip tool class
Exception (abnormal) and Error (error) difference analysis
【特征选取】计算数据点曲率
Tag stack - stack monotonically preparatory knowledge - lt. 739. The daily temperature
Djiango第二次培训
Djiango第三次培训
获取Ip工具类
VSO Downloader Ultimate 5.0.1.45 中文多语免费版 在线视频下载工具
1060 爱丁顿数 (25 分)