当前位置:网站首页>-整数求和-
-整数求和-
2022-08-03 05:10:00 【-JMY-】
题目描述
已知:S= 1+2+3+...+n。显然对于任意一个整数K,当n足够大的时候,S大于K。现给出一个整数K(1<=k<=10000000),要求计算出一个最小的n,使得S>K。
输入
一个整数k
输出
输出满足条件最小的n
样例输入
9
样例输出
4
参考代码:
#include<iostream>
using namespace std;
int main(){
int S=0,n=0,k;
cin>>k;
while(S<=k){
n++;
S+=n;
}
cout<<n;
return 0;
}
边栏推荐
猜你喜欢
typescript43-类型兼容性说明
[Harmony OS] [ArkUI] ets development graphics and animation drawing
如何不耍流氓的做运维之-SHELL脚本
web安全-sql注入漏洞
web安全-SSTI模板注入漏洞
Build your own web page on the Raspberry Pi (2)
2017-06-11 Padavan 完美适配newifi mini【adbyby+SS+KP ...】youku L1 /小米mini
13.< tag-动态规划和回文字串>lt.647. 回文子串 + lt.516.最长回文子序列
Install PostgreSQL on Windows
3. 无重复字符的最长子串
随机推荐
Ali cloud object storage oss private barrels to generate links
Interface test framework combat (1) | Requests and interface request construction
背压机制
FileZilla 搭建ftp服务器
Kaggle(四)Scikit-learn
传说中可“免费白拿”的无线路由器 - 斐讯 K2 最简单刷 breed 与第三方固件教程
web安全-SSTI模板注入漏洞
Exception (abnormal) and Error (error) difference analysis
数字孪生园区场景中的坐标知识
Talking about GIS Data (5) - Geographic Coordinate System
【Biotin Azide|cas:908007-17-0】Price_Manufacturer
MOSN 反向通道详解
presto安装部署教程
1060 爱丁顿数 (25 分)
Build your own web page on raspberry pie (1)
C# async and multithreading
High availability, two locations and three centers
Newifi路由器第三方固件玩机教程,这个路由比你想的更强大以及智能_Newifi y1刷机_smzdm
ss-1.curl (cloud-provider-payment8001)
Harmony OS Date ano UI 】 【 】 the basic operation