当前位置:网站首页>精彩编码 【进制转换】
精彩编码 【进制转换】
2022-07-06 11:47:00 【全栈程序员站长】
大家好,又见面了,我是全栈君。
精彩编码 Description 如果没有阿拉伯数字,我们想得到怎样来表示数字 小明觉得一个方法,如下面的: 1 -> A 2 -> B 3 -> C …. 25 -> Y 26 -> Z 27 -> AA
28 -> AB ….
如今请你写一个程序完毕这个转换
Input 输入的第一个数为一个正整数T,表明接下来有T组数据。 每组数据为一个正整数n ( n <= 1000)
Output 对于每一个正整数n,输出他相应的字符串
Sample Input 3 1 10 27 Sample Output A J AA
进制转换?
#include <stdio.h>
#include <iostream>
#include <math.h>
#include <stdlib.h>
#include <ctype.h>
#include <algorithm>
#include <vector>
#include <string.h>
#include <queue>
#include <stack>
#include <set>
#include <sstream>
#include <time.h>
#include <utility>
#include <malloc.h>
#include <stdexcept>
#include <iomanip>
#include <iterator>
using namespace std;
int main()
{
int n,t;
scanf("%d",&t);
while (t--)
{
scanf("%d",&n);
if (n <= 26)
printf("%c\n", 'A' + n - 1);
else if (n <= 26 * 26 + 26)
{
n -= 27;
int t = n / 26;
printf("%c", 'A' + t);
n = n % 26;
printf("%c\n", 'A' + n);
}
else
{
n -= 27 + 26 * 26;
printf("%c%c%c\n", 'A' + char(n / 26 / 26), 'A' + char((n / 26) % 26), 'A' + char(n % 26));
}
}
return 0;
}
版权声明:转载请注明出处。
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117143.html原文链接:https://javaforall.cn
边栏推荐
- About image reading and processing, etc
- It's enough to read this article to analyze the principle in depth
- 手把手教你学会js的原型与原型链,猴子都能看懂的教程
- 腾讯T3大牛手把手教你,大厂内部资料
- IC设计流程中需要使用到的文件
- Zero foundation entry polardb-x: build a highly available system and link the big data screen
- 在解决了 2961 个用户反馈后,我做出了这样的改变...
- 深入浅出,面试突击版
- Documents to be used in IC design process
- Black Horse - - Redis Chapter
猜你喜欢
保证接口数据安全的10种方案
CPU负载很低,loadavg很高处理方法
Mysql Information Schema 學習(一)--通用錶
在解决了 2961 个用户反馈后,我做出了这样的改变...
LeetCode_双指针_中等_61. 旋转链表
Chic Lang: attributeerror: partially initialized module 'CV2' has no attribute 'GAPI_ wip_ gst_ GStreamerPipe
Information System Project Manager - Chapter VIII project quality management
腾讯T3大牛手把手教你,大厂内部资料
Druid database connection pool details
学习探索-无缝轮播图
随机推荐
POJ 3207 Ikki&#39;s Story IV – Panda&#39;s Trick (2-SAT)
MySQL information schema learning (I) -- general table
Interpretation of Dagan paper
How to do smoke test
PMP practice once a day | don't get lost in the exam -7.6
A5000 vGPU显示模式切换
How can my Haskell program or library find its version number- How can my Haskell program or library find its version number?
Excel 中VBA脚本的简单应用
【pytorch】yolov5 训练自己的数据集
Mysql Information Schema 学习(二)--Innodb表
Recursive implementation of department tree
Tensorflow2.0 self defined training method to solve function coefficients
1805. 字符串中不同整数的数目
《数字经济全景白皮书》保险数字化篇 重磅发布
[translation] micro survey of cloud native observation ability. Prometheus leads the trend, but there are still obstacles to understanding the health of the system
Dom 操作
【翻译】Linkerd在欧洲和北美的采用率超过了Istio,2021年增长118%。
How to customize animation avatars? These six free online cartoon avatar generators are exciting at a glance!
Reflection and illegalaccessexception exception during application
力扣101题:对称二叉树