当前位置:网站首页>Haut OJ 1316: sister choice buys candy III
Haut OJ 1316: sister choice buys candy III
2022-07-05 05:16:00 【hunziHang】
Problem description :
Choice The schoolgirl looks at so many sweets in the candy store , She thought it would be great if she could take them all home . Now there are n Grow candy (1-n Number ), Each kind of candy has mi individual (mi On behalf of the i The number of candies ),Choice The student sister only has two paper bags , Each paper bag can hold at most w A candy .Choice The schoolgirl doesn't want a paper bag mixed with a variety of sweets ( One paper bag at a time can only contain one kind of candy ), that Choice How many times does the schoolgirl have to take all these sweets home at least ?
Input :
Enter two integers on the first line n,w(1 <= n ,w<= 1e4), Space off
Next line n Space separated integers mi, It means the first one i The number of candies .(1<= mi <= 1e3).
Output :
How many times should I take the output at least , The answer is on one line .
The sample input :
6 5 3 2 6 5 4 4
Sample output :
4
Cause analysis :
Calculate the total number of bags needed , Number of bags /2 According to the circumstances , Because because / The result is an integer , That is, odd numbers will be rounded down , One less time , So you can Odd number Even numbers Merge (ans+ 1) / 2 for example 7/2=3 , Mathematically, it should be equal to 3.5, The actual need 4 Time , even numbers 8 need 4 Time , Add 1 There are still four times Actually ans/2 + 0.5 +0.5 It is equivalent to rounding
in the future Practical application /2 Remember to think about Odd and even cases , Whether it will have an impact
Solution :
#include <stdio.h>
int main()
{
int n, w, t;
int ans = 0;
scanf("%d%d", &n, &w);
for(int i = 1; i <= n; i++) {
scanf("%d", &t);
ans += t / w;
if(t % w)
ans ++;
}
printf("%d\n", (ans+ 1) / 2);
return 0;
}
边栏推荐
- C language Essay 1
- Under the national teacher qualification certificate in the first half of 2022
- Insert sort
- C4D simple cloth (version above R21)
- Applet live + e-commerce, if you want to be a new retail e-commerce, use it!
- Es module and commonjs learning notes -- ESM and CJS used in nodejs
- 2022/7/2做题总结
- Out and ref functions of unity
- Magnifying glass effect
- Shell Sort
猜你喜欢
随机推荐
Basic knowledge points of dictionary
Simple modal box
What is the agile proportion of PMP Exam? Dispel doubts
Unity check whether the two objects have obstacles by ray
cocos2dx_ Lua card flip
服务熔断 Hystrix
Simple HelloWorld color change
Transport connection management of TCP
Vs2015 secret key
Quick sort summary
Unity synergy
远程升级怕截胡?详解FOTA安全升级
Three dimensional dice realize 3D cool rotation effect (with complete source code) (with animation code)
[turn]: Apache Felix framework configuration properties
2022/7/2 question summary
[allocation problem] 455 Distribute cookies
Double pointer Foundation
Out and ref functions of unity
Pause and resume of cocos2dx Lua scenario
To the distance we have been looking for -- film review of "flying house journey"